Hi i have been given a Team class and was asked to make a subclass RugbyTeam from it.
The only abstract method in Team i have to implement is
I know how to implement it, the only thing conufusing me is the parameter variable name iProblemsSolved. For the rugby subclass should have a parameter name called goalsScored not iProblemsSolved because rugby teams score goals. Is it ok to rename this new methods parameter variable goalsScored in the RugbyTeam subclass or is this against convention.
It compiles fine as you will know. Or should the Team class abstract methods parameter variable name be renamed to comething more generic like pointsScored?
Can i have straight forward answers please, no "i think" answers. Was getting them on another forum which confused me more.