aspose file tools*
The moose likes Tomcat and the fly likes Tomcat 6.0.18 - 5.5.25 or hibernate 3 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Tomcat
Reply locked New topic
Author

Tomcat 6.0.18 - 5.5.25 or hibernate 3

Kris Reid
Ranch Hand

Joined: Jan 05, 2005
Posts: 247
Hi

I've developed an application on my machine using tomcat 6.0.18, Java 1.6 and Hibernate 3.
Works a treat!

Until I went to pass the WAR over to a remote server running Tomcat 5.5.25
The application loads and works for a few queries to the database but then throws
com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications link failure

I don't think it has anything to do with the remote servers setup or mysql has anything to do with it.
As I installed Tomcat 5.5.25 on another local machine and could recreated the problem.

Any idea how to resolve it?

Cheers

Kris
Kris Reid
Ranch Hand

Joined: Jan 05, 2005
Posts: 247
I don't think this is actually a problem with tomcat.
I think it is Mysql closing the connection to Hibernate.

I posted a question in the hibernate forum
http://www.coderanch.com/t/439221/Object-Relational-Mapping/java/MySQLNonTransientConnectionException-No-operations-allowed-after#1953125
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Tomcat 6.0.18 - 5.5.25 or hibernate 3