aspose file tools*
The moose likes Java in General and the fly likes Implementing Drools in Java Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Java in General
Bookmark "Implementing Drools in Java" Watch "Implementing Drools in Java" New topic
Author

Implementing Drools in Java

Arc Sa
Greenhorn

Joined: Apr 08, 2009
Posts: 8
Can anybody tell me if drools can be used in jdevloper(jdk 1.4). Because in every eg download I find drools with eclipse. Am very new to this. Since i din find any forum for rule engine i had to post it here. So anybody interested can give other related informations also. It would help me so much. Thanks in advance
Ulf Dittmer
Marshal

Joined: Mar 22, 2005
Posts: 42602
    
  65
Drools is a Java library like any other - it can be used with any IDE, or without one. What problems have you encountered using it with JDeveloper?


Ping & DNS - my free Android networking tools app
Arc Sa
Greenhorn

Joined: Apr 08, 2009
Posts: 8

Am yet to use it. Should i develop the related jar files or can i download it from somewhere? First i thought i could know something about it with an example,but it works with jdk1.5 whereas in my proj we use jdk1.4. Can you tell me how and where to start?
Ulf Dittmer
Marshal

Joined: Mar 22, 2005
Posts: 42602
    
  65
Should i develop the related jar files or can i download it from somewhere?

I'm not sure what you mean by "develop" - what's wrong with downloading and using it?

The Drools 4 documentation specifically mentions that "at its core only Java 1.4 (J2SE) is required."
Arc Sa
Greenhorn

Joined: Apr 08, 2009
Posts: 8
Thanks a lot. But i found in Drools documentation that
Drools 4.0.7 works with JDK1.5 and above.

and Drools 3.0.6 works with JDK1.4 and above. But i cant find the exact location for Drools 3.0.6 download.
Kindly correct me if am wrong
Ulf Dittmer
Marshal

Joined: Mar 22, 2005
Posts: 42602
    
  65
Interesting. Section 3.1 in http://downloads.jboss.com/drools/docs/4.0.7.19894.GA/html/index.html mentions the Java 1.4 minimum.
Arc Sa
Greenhorn

Joined: Apr 08, 2009
Posts: 8
Yes but in section 3.2 it is given
Drools works with JDK1.5 and above.
Am really confused. Can you please clear me?
Ulf Dittmer
Marshal

Joined: Mar 22, 2005
Posts: 42602
    
  65
Section 3.2 is about building from source, which for some reason may indeed require Java 5, even though the final library works fine with Java 1.4.

The easy way would be to just try to use it with Java 1.4.
Arc Sa
Greenhorn

Joined: Apr 08, 2009
Posts: 8
Ok I will try using Drools 4. Thanks a lot .
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Implementing Drools in Java