This week's giveaway is in the EJB and other Java EE Technologies forum.
We're giving away four copies of EJB 3 in Action and have Debu Panda, Reza Rahman, Ryan Cuprak, and Michael Remijan on-line!
See this thread for details.
The moose likes JBoss/WildFly and the fly likes Configure JBoss to connect to remote queues Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "Configure JBoss to connect to remote queues" Watch "Configure JBoss to connect to remote queues" New topic
Author

Configure JBoss to connect to remote queues

Scott Selikoff
Saloon Keeper

Joined: Oct 23, 2005
Posts: 3697
    
    5

I've completely the integration of MDBs on JBoss using ActiveMQ and everything works fine. In particular:

  • The header of my MDB has references to the ActiveMQ Adapter


  • Added activemq-jms-ds.xml to the deploy directory and configured it properly
  • Created directory activemq-rar-5.2.0.rar in the deploy directory and configured it properly


  • My question is this... without breaking the current setup, how do I allow an MDB to connect to a remote ActiveMQ instance?

    Also, let's say I want to run ActiveMQ as a stand alone process outside of JBoss. Is there a simple switch to turn off ActiveMQ from starting up without breaking the connectors? Every time I tried to turn off ActiveMQ, my MDBs failed to deploy properly. Basically, I'd like the connector aspect of ActiveMQ to be used with the server as being optional.


    My Blog: Down Home Country Coding with Scott Selikoff
    Scott Selikoff
    Saloon Keeper

    Joined: Oct 23, 2005
    Posts: 3697
        
        5

    Figured it out, all the changes can be made in:
    activemq-rar-5.2.0.rar\META-INF\ra.xml

    To use a remote source, change the resourceadapter/config-property ServerURL to something like this:

    Where myServer is the address of the remote server.

    The second step to disable the embedded broker is to disable the resourceadapter/config-property BrokerXmlConfig section all together. It's the one that calls the broker-config.xml file in the JBoss solution. Removing this section will keep the connector in tact but not cause the broker to start.
     
    I agree. Here's the link: http://aspose.com/file-tools
     
    subject: Configure JBoss to connect to remote queues
     
    Similar Threads
    Error while deploying EJB3 mdb on Jboss 6
    ActiveMQ ERROR [Managed Region Broker] Failed to register destination queue://
    How to listen to remote Topic in MDB 3.0
    JBoss and MDB (configuration question)
    MDB Listenign to remote queue