Bookmark Topic Watch Topic
  • New Topic

JMS Queue

 
Shyam Hai
Ranch Hand
Posts: 68
  • Mark post as helpful
  • send pies
  • Report post to moderator

I changed the java version( 1.4 to 1.5) in Eclipse3.1

After that i got one error in jms Queue.

Error : "The type Queue is ambiguous"

How to rectify this error.

Thank you...........
 
Joanne Neal
Rancher
Posts: 3742
16
  • Mark post as helpful
  • send pies
  • Report post to moderator
Java 5 introduced the java.util.Queue class.
I assume you are importing java.util.*.
Your options are to
1. change this so you only import the specific classes you use
2. use the full class name of the javax.jms.Queue class wherever you refer to it.
 
Maneesh Godbole
Saloon Keeper
Posts: 11021
12
Android Eclipse IDE Google Web Toolkit Java Mac Ubuntu
  • Mark post as helpful
  • send pies
  • Report post to moderator
Ragavendran,

Please do not post the same question on multiple forums.
Let is continue the discussion at http://www.coderanch.com/t/440926/IDEs-Version-Control-other-tools/Java-IDE-with-jms
 
    Bookmark Topic Watch Topic
  • New Topic