This week's book giveaways are in the Refactoring and Agile forums.
We're giving away four copies each of Re-engineering Legacy Software and Docker in Action and have the authors on-line!
See this thread and this one for details.
Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Cloud/Virtualization forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Difference Between Struts 1.0 and Struts 1.1

 
sumanta panda
Ranch Hand
Posts: 224
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Dear All,
Could you please advise me for the below needful.

  • what is the Difference between struts 1.0 and struts 1.1?


  • How to proceed when we migrate our application from struts 1.0 to struts 1.1?



  • Thanks in advance.

    Best Regards,
    Sumanta Panda
     
    David Newton
    Author
    Rancher
    Posts: 12617
    IntelliJ IDE Ruby
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    http://struts.apache.org/1.1/userGuide/release-notes-1.1.html

    Why would you bother migrating to 1.1? If you're going to go to all the trouble to migrate to another version of Struts why not move to one that's actually maintained?
     
    sumanta panda
    Ranch Hand
    Posts: 224
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    Dear David,
    We want to migrate struts 1.0 to struts 1.1 because presently our application using WAS 5.1 server which is supporting to Struts 1.0.

    As per the requirement of our client we have to Migrate WAS 5.1 to WAS 6.1 server.

    WAS 6.1 server is not supporting Struts 1.0 .So it is supporting Struts 1.1.So we need to migrate struts 1.1 also.

    Please advise me how i will proceed to do the needful.

    Thanks!!!

    Sumanta Panda

     
    David Newton
    Author
    Rancher
    Posts: 12617
    IntelliJ IDE Ruby
    • Mark post as helpful
    • send pies
    • Quote
    • Report post to moderator
    I recommend against migrating to such an old version of Struts. WAS 6.1 should support at *least* 1.2.9, if not 1.3.x.

    See StrutsUpgrade for 1.0 => 1.2.

    I see zero point in upgrading to 1.1; it's just not a good idea.
     
    • Post Reply
    • Bookmark Topic Watch Topic
    • New Topic