Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Cloud/Virtualization forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Problem running a simple webapplication in struts

 
Varun Nayudu
Ranch Hand
Posts: 159
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi

I am having problem running a simple webapp in struts here is the full code with the error

URL:
http://localhost:8181/StrutsApp2/UserRegistrationAction.do

web.xml:


struts-config.xml:


Action class


Error which i got

 
Balu Sadhasivam
Ranch Hand
Posts: 874
Android Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator



is it action-mapping or action-mappings ?
 
Varun Nayudu
Ranch Hand
Posts: 159
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks man for your answer.



I am still having the same error


 
Balu Sadhasivam
Ranch Hand
Posts: 874
Android Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Few silly mistakes i can see in struts config. Please check out some tutorial struts-config before any queries

Couple of things to note
Your action path and html form action should match.
Restart the server after the changes
 
Varun Nayudu
Ranch Hand
Posts: 159
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Balu Sadhasivam wrote:
Few silly mistakes i can see in struts config. Please check out some tutorial struts-config before any queries

Couple of things to note
Your action path and html form action should match.
Restart the server after the changes


Thanks for your reply I went through the documentation but still i cant find the error what is casing this, I changed the struts-config.xml



Now please tell me what am i doing wrong ...
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Are there any startup warnings in the log file?
 
Varun Nayudu
Ranch Hand
Posts: 159
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ya actually there were

Here it is

 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'd start by fixing that; your application isn't starting up.
 
Balu Sadhasivam
Ranch Hand
Posts: 874
Android Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Varun Nayudu wrote:
Thanks for your reply I went through the documentation but still i cant find the error what is casing this, I changed the struts-config.xml



What is the change you did ? Is it a valid xml ? Does it have valid DOCTYPE DTD declaration at the start ?
check this struts-config.xml

Also, action path must start with "/". First make sure the server startups without errors.




 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic