Win a copy of The Java Performance Companion this week in the Performance forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

WAS 6.1 server supporting which version of Struts,JDK,EJB,JSP and Servlet

 
sumanta panda
Ranch Hand
Posts: 224
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Dear All,
In our Application we are going to Migrate the server from WAS 5.1 to WAS 6.1?

Presently in our application we are using Struts 1.0,Jdk 1.4,EJB 2.0,JSP 1.2 and Servlet 2.3. for WAS 5.1 server.

We are planning to Migrate WAS 5.1 to WAS 6.1.

For WAS 6.1 which version we are Using for Struts,JDK,EJB,JSP and Servlet?
Please suggest me the lower and higher version of Struts,JDK,EJB,JSP and Servlet supporting for WAS 6.1.


Thanks in advance.

Best Regards,
Sumanta Panda
 
abhishek khandelwal
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Sumanta,

The WAS6.1 does provide the backward compatibility with all the versions of struts, JDK & J2EE technologies that was supported by WAS5.1.

So if you are just planning the application server migration than you can just go ahead with the straight deployment of existing EAR to new server, But if you want to migrate to latest specifications than i would rather suggest an incremental approach i.e. move from struts 1.0 to struts 1.3, JDK1.4 to 1.5 & J2EE 1.2/1.3 to 1.4.

If you are looking for the highest supported versions than please have a look of the IBM WAS6.1 tech documentations.

Please let us know if need more information.

 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic