• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

web project running problem jboss4.2.3

 
Ami Ambre
Ranch Hand
Posts: 58
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have configured JBoss 4.2.3.ga with eclipse europa 3.3.1.1.
Problem is When i running any web project Dynamic or static.
when i added Jsp file to web project & write it anything on to that But when i saved it, it would not get saved.
As well as when i run JBoss after adding jsp file to project it will ask me Do you want to save jsp file or not?
so i have select it no then & then Jboss get started but that jsp file would not saved. If i choose yes then it would not get saved & would not started.
Please give me solution on to this toipc.
 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You lost me, I have no idea what you are saying yes or no too. Please provide a list of the exact steps you did and identify what did not work as you expected.

I have not had any problems with working with JSPs in a dynamic web project, nor in having the JSP be deployed when changed, though often I have to refresh the browser to get it to pick up the updated JSP.
 
Ami Ambre
Ranch Hand
Posts: 58
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Peter I am really in problem.
When i am doing any Dynamic/static project.
and adding jsp or html file to that project. But after complition of adding anything to jsp file
it would not get saved.it will always given me save failed org.eclipse.ui.texteditor.abstractTextEditor.createSaveOperation(z) Lorg/eclipse/ui/actions/workspaceModifyOperation(z);

as well as my second problem is when i am starting server it take too much time. & at the it will showing messageBox Timeout waiting for JBoss 4.2 Server to Start. Server did not start after 450s
 
Kaustubh Patil
Ranch Hand
Posts: 164
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Let me try to comprehend this...

Ami,
Your problem seems more or less with the eclipse workspace rather than jboss. Check if the file you are editing is read-only. If you have mapped your eclipse project source directory to some folder in source control tool etc.. etc..

regarding the server not starting.. I am not getting why are you not able to start it. As Peter said, tell the exact steps you did to start the server.
 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ami, were you at any time able to save the JSP file without problems? If so, what did you do to the file between the time you last saved it and the time that it refised to save?

If you were never able to save a JSP, then I suspect that your Eclipse configuration, or your workspace, is corrupted. First, starting Eclipse in a new workspace and try yoru project there. If that still does not work, reinstall Eclipse.

Also, have you looked at JBoss Tools? The Tools documentation has several good tutorials to get you started.
 
Ami Ambre
Ranch Hand
Posts: 58
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Now My JBoss is properly working.
But after changing workspace of eclipse jsp still giving problem at the time of saving.
An error has occurred. See error log for more details.
Org/eclipse/ui/internal/services/ISerivceLocatorCreator
please help me.
 
Kaustubh Patil
Ranch Hand
Posts: 164
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
do you see anything in the eclipse logs ? The logs might be here,
<your workspace folder>\.metadata\.log
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic