jQuery in Action, 2nd edition*
The moose likes Developer Certification (SCJD/OCMJD) and the fly likes URLyBird: RMI Server Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Certification » Developer Certification (SCJD/OCMJD)
Bookmark "URLyBird: RMI Server" Watch "URLyBird: RMI Server" New topic
Author

URLyBird: RMI Server

Alexandre Baldo
Ranch Hand

Joined: Aug 04, 2006
Posts: 48
Hello, all!!

I have to questions about RMI Server:

#1: When I run the client app and it connects to the rmi server two file are created: suncertify.properties (that's ok) and a blank xxx.db file. I don't know why it is creating the db file.

#2: When I run the client app in the same network the server is the connection with the server is ok! But if I try to run the client from a different network it connects to the server but than for any other action (search, for instance) it says that the connection was refused by the server... I've configured the port forwarding in my router but it still didn't work...

Can anyone help me??

Thank's in advance!


...ops!<br>-----------------<br>
SCJD<br>
SCWCD 1.4<br>
SCJP 1.4
Roberto Perillo
Bartender

Joined: Dec 28, 2007
Posts: 2258
    
    3

Howdy, Alexandre!!!

For question #1, this shouldn't really be happening, so you'll have to investigate closely what's wrong (it's kindda' hard to tell what is wrong without seeing the code )

For question #2, I assumed the server and the client would always be running in the same network, so if you can have a client connect to the server from the same network, it should be ok!


Cheers, Bob "John Lennon" Perillo
SCJP, SCWCD, SCJD, SCBCD - Daileon: A Tool for Enabling Domain Annotations
Alexandre Baldo
Ranch Hand

Joined: Aug 04, 2006
Posts: 48
#1: I'll debug the code again to see what is going on...
#2: It is working when the client and server are in the same network! So I will not worry about that...

Thank's for your reply, Roberto!
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: URLyBird: RMI Server
 
Similar Threads
accessing database on server from a local machine as when required
client and database URLyBird
The mode flag
RMI app - java.rmi.ConnectException
TCP Sampler in jmeter to test client-server