File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Tomcat and the fly likes Welcome page not showing Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Welcome page not showing" Watch "Welcome page not showing" New topic
Author

Welcome page not showing

Tim-Ting Chang
Greenhorn

Joined: Jan 13, 2009
Posts: 25
I downloaded the .zip version of tomcat from apache website. copy them to my "program files" folder. I started tomcat by clicking the "startup.bat" file under the "/bin" directory under tomcat home directory. Windows informed my that tomcat server started up in 125 ms. My tomcat ver. is 5.5.

When I type "http://localhost:8080/" the IE hangs a long time and eventually says it couldn't reach the page. I tried "netstat -a" command on my computer and it verifies that TCP port 8080 is being listened by my computer. I checked the "server.xml" under the "/conf" directory and it verifies that 8080 is assigned to http requests, like:



I tried different URL like "http://127.0.0.1:8080/" or "http://localhost:8080/example" or "http://localhost:8080/index.jsp", but none worked. Project manual didn't mention how to deal with such errors, neither could i find other relevant posts. I assigned JAVA_HOME var. but not the CATALINA_HOME, since I always start from the tomcat directory.

I could probably try installing tomcat as a win service, but i'd like to figure out why my unzipped tomcat server didn't work before i move on.

I just re-installed windows and have not install anything else that might interfere (like oracle's http server which also uses 8080), not even anti-virus. I use jdk6.
William Brogden
Author and all-around good cowpoke
Rancher

Joined: Mar 22, 2000
Posts: 12785
    
    5
Instead of clicking on startup.bat, open a command prompt window, change to the bin directory and execute startup.bat from the command line. There may be some startup error messages you are missing.

When you say "Windows informed my that tomcat server started up" where do you see that message?

Are you sure "localhost" is defined on your computer?

Can you see the tomcat task running in the windows Task manager?

I recommend setting CATALINA_HOME anyway.

Bill
Tim-Ting Chang
Greenhorn

Joined: Jan 13, 2009
Posts: 25
William Brogden wrote:Instead of clicking on startup.bat, open a command prompt window, change to the bin directory and execute startup.bat from the command line. There may be some startup error messages you are missing.

The command prompt output says:

When you say "Windows informed my that tomcat server started up" where do you see that message?

A second MS-DOS prompt appears, describing the tomcat startup process, ending with the statement:

There are some exceptions, regarding log access denial. There are too many lines displayed. I can't make sense of them.
I defined JAVA_HOME to my jdk base directory already, as I just verified with the User Account under Windows.
William Brogden wrote:
Are you sure "localhost" is defined on your computer?

How do you check?
Can you see the tomcat task running in the windows Task manager?

Under the "Applications" of the task manager, I can see "Tomcat" application with Status "Running", but I cannot find it under the "Processes" tab.
I recommend setting CATALINA_HOME anyway.

I did, as the output showed earlier.

Last time similar things happened when I use tomcat 6. The problem I had went away after I stepped down to tomcat 5.5. I am using 5.5 now, and I think I am doing everything right (as I have set up tomcat before).

I appriciate for any help you can give.
Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 61218
    
  66

"coolfish loopy", please check your private messages for an important administrative matter.

[Asking smart questions] [Bear's FrontMan] [About Bear] [Books by Bear]
Seetharaman Venkatasamy
Ranch Hand

Joined: Jan 28, 2008
Posts: 5575

William Brogden wrote:
I recommend setting CATALINA_HOME anyway.

Well William,

please Can i know the reason? because only after setting JAVA_HOME ,tomcat is running.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Welcome page not showing