wood burning stoves 2.0*
The moose likes Websphere and the fly likes Problem in connecting to WebSphere MQ Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Websphere
Bookmark "Problem in connecting to WebSphere MQ" Watch "Problem in connecting to WebSphere MQ" New topic
Author

Problem in connecting to WebSphere MQ

Vijay Chandran
Ranch Hand

Joined: Jan 07, 2007
Posts: 178
Dear friends,

I have configured the Queue Connection factory and Queues in Websphere 6.1.0.
The queues point to the Websphere MQ V6.0 JMS provider.

I have written the following code:


When i execute it, i get the following exception:
javax.jms.JMSException: MQJMS1092: userid must be less than 12 characters

I cannot change the user name because i'm not the system admin.

Is there anyway to disable the security in Websphere application server when connecting to Wesphere MQ. Its not a problem to disable because i'm just using it for testing purpose.

Please help me resolving the issue.

Thanks & Regards,
Vijay


juan diego navarre
Greenhorn

Joined: Apr 27, 2009
Posts: 6
Are you using MQSeries?
Vijay Chandran
Ranch Hand

Joined: Jan 07, 2007
Posts: 178
Hi,

I don't know anything about MQ Series. I am using WebSphere MQ V6.0
juan diego navarre
Greenhorn

Joined: Apr 27, 2009
Posts: 6
Ok, then try using a queueconnection without user
Jay Olsen
Greenhorn

Joined: Jan 26, 2008
Posts: 10
Another option would be to take the security creditionals out of the code and specify them using JAAS which can then be applied to the QCF.
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Problem in connecting to WebSphere MQ