wood burning stoves*
The moose likes Websphere and the fly likes Migration issue : Portlet Application (JSF frmwork) from WPS 5.1 to WPS 6.1 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Websphere
Bookmark "Migration issue : Portlet Application (JSF frmwork) from WPS 5.1 to WPS 6.1" Watch "Migration issue : Portlet Application (JSF frmwork) from WPS 5.1 to WPS 6.1" New topic
Author

Migration issue : Portlet Application (JSF frmwork) from WPS 5.1 to WPS 6.1

sujith Acharya
Ranch Hand

Joined: Dec 25, 2006
Posts: 60
are planning to migrate our portal application from Websphere Portal server 5.1 to Websphere Portal server 6.1.
The application is developed in Portal server 5.1 in RAD 6 using IBM depricated API with Faces Portlet(JSF Framework).

In Red book "IBM WebSphere Portal V6: Best Practices for Migrating from V5.1" page number 22, its mentioned that
"Portlets developed by using the IBM API that use the Java Server Faces (JSF) framework will not work with WebSphere Portal V6 if they were developed using Rational Application Developer V6 .The following Web site provides additional information about portlets
developed using Rational Application Developer V6.

what approach should I follow if I want to migrate the appllication to Websphere Portal server 6.1.
Cameron Wallace McKenzie
author and cow tipper
Saloon Keeper

Joined: Aug 26, 2006
Posts: 4968
    
    1

It's really more to do with the portlet bridge than the application itself.

In RAD, create a new version 6 portlet project that uses the latest Java Server Faces facet, and then copy the old code and resources into the new web project. Then you can deploy the new, updated JSF application from IRAD to WebSphere Portal Server.

-Cameron McKenzie
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Migration issue : Portlet Application (JSF frmwork) from WPS 5.1 to WPS 6.1