File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Websphere and the fly likes How to installa a plugin in RAD 7.5 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Products » Websphere
Bookmark "How to installa a plugin in RAD 7.5" Watch "How to installa a plugin in RAD 7.5" New topic
Author

How to installa a plugin in RAD 7.5

pepe lotas
Greenhorn

Joined: Feb 20, 2009
Posts: 10
Hi everyone!!

I have been working for a while with RAD 7.0, and now I changed to RAD 7.5.

I used to use checkStyle plugin in RAD 7.0, I found in the internet how to install that plugin in RAD 7.0 and it worked ok. But now, I'm trying to install it in RAD 7.5 and I'm unable to do it.
Can anyone tell me how to do it?

I tried to install it like I did in RAD 7.0 but it does not work.

I searched google but I did not find an answer

I go to "help --> software update" then the tab "available software", "add site", "local", and ther I look for a folder where the plugin is, and in the same folder or in the one upper, I set an empty ".eclipseextension" named file. But it says there is nothing there.
And I tried the other option instead of "local" pointing to the .zip file of the plugin, and decompressing it and pointing to the different .zip files, but nothing worked

Can anyone help me please!!

Thanks in advance!!

EDIT: I forgot to say, I found this page,
https://jazz.net/learn/tech-notes/TechNote.jsp?href=data/rtc-1_0-rad-7_5-coexistence/index.html
with a explanation and a screenshoot, I try it, but I do not get to see the right side, where it says "Rational Application Developer" and "Add an extension location" that is what I used in RAD 7.0. Where is that !?!?!?!? that is all I need!!
Cameron Wallace McKenzie
author and cow tipper
Saloon Keeper

Joined: Aug 26, 2006
Posts: 4968
    
    1

Which plugin are you adding? Usually just extracting the associated zip file into the plugins directory does the trick.

The plugin itself usually comes with a readme.txt file that describes the installation process. Is there one in the zip file?

-Cameron McKenzie
pepe lotas
Greenhorn

Joined: Feb 20, 2009
Posts: 10
Cameron Wallace McKenzie wrote:Which plugin are you adding? Usually just extracting the associated zip file into the plugins directory does the trick.

The plugin itself usually comes with a readme.txt file that describes the installation process. Is there one in the zip file?

-Cameron McKenzie


Oh my goodness!!! It worked!!

I have been using eclipse for a long time, and every plugin I installed, I did it that way, copying it to the eclipse\plugin folder.
But since I use RAD 7.0 that way did not work, so when I have changed to RAD 7.5 I guessed it would not work either so I was so stupid I did not even try

By the way, the plugin is "CheckStyle"

Thanks a lot!!
Cameron Wallace McKenzie
author and cow tipper
Saloon Keeper

Joined: Aug 26, 2006
Posts: 4968
    
    1

What's old is new again!

Plugin configuration in Eclipse is always hit and miss. Dont' feel bad. I'm glad you got it working.

-Cameron McKenzie
Shanmugam Muthukumarasamy
Ranch Hand

Joined: Jan 11, 2003
Posts: 83
I am trying the same thing for JADEclipse plugin (JAD Decompiler). With RAD 7.0 I have this plugin copied under eclipse\plugin folder and it was working. And now I am using RAD 7.5 and I don't know where to keep this plugin. I can't find the eclipse\plugin folder under RAD 7.5 installation directory.

Any help please?

thanks,
Shan


SJCP 1.4<br />SCWCD 1.4<br />SCEA
pepe lotas
Greenhorn

Joined: Feb 20, 2009
Posts: 10
Hi Shanmugam Muthukumarasamy!!

I have a folder called "C:\Archivos de programa\IBM\SDP" may be yours is "C:\program files\IBM\SDP".

There I have "eclipse.exe" that is what is executed when you open RAD 7.5

My start button link for the program properties says: ""C:\Archivos de programa\IBM\SDP\eclipse.exe" -product com.ibm.rational.rad.product.v75.ide"
That opens RAD 7.5

Then, I have my checkstyle plugin folder in the same folder, I mean here "C:\Archivos de programa\IBM\SDP" so I have this
"C:\Archivos de programa\IBM\SDP\com.atlassw.tools.eclipse.checkstyle_3.5.0"

I do not have a "plugins" folder either, so I put the plugin folder there and it works.

If it did not work, you could also create a folder called "plugins" in "C:\Archivos de programa\IBM\SDP" and try copying the plugin there.


Hope this helps and you get it!!

cheers!!
Mujeebur Rahman
Greenhorn

Joined: Jul 10, 2008
Posts: 20
Hi,

RAD 7.5 now using the Eclipse 3.4's feature of Equinox P2 Update mechanism. This is much more sophisticated and easy way of installing/updating 3rd party plug-ins .

Here are steps in brief

1. In the Available Software tab, Click on "Add Site" and add the URL(repository of the plug-in).

2. Now click on the newly added site and install the plug-in from the list

3. Restart RAD/ Eclipse


You can still use the old way of installing like Software Update -- Find and Install but to do this you need to enable the capablity "classic update" from Prefefrences--General--Capablities--Classic Update. If you enable this, you will get two software update submenu in Help. The first one will be old style (classic update) the second one will be new way of installing plug-ins.

Let me know the results.

Regards,
Mujeebur Rahman
Shanmugam Muthukumarasamy
Ranch Hand

Joined: Jan 11, 2003
Posts: 83
Thank you for the different options...and here is what I tried so far

I used to setup the JADEclipse plugin in RAD 7.1 as per the instructions from the link below

http://www.devx.com/Java/Article/22657

I want to have the JADEclipse plugin incorporated to the RAD 7.5 and I don't know how to do. The reason is there is no eclipse\plugin folder anywhere under the RAD 7.5 installation directory. Even I kept this plugin under the SDP\Plugins and SDPShared\Plugins, but it is not picking up the plugin.

I have enabled the classic update in RAD and also I tried adding the Local and Remote sites (one at a time) with the respective URLs. It complains that there is no update site available for the selected site. I think it expects the site.xml with the JADEclipse plugin. But in the the JAR file I see only the plugin.xml and I don't see any site.xml.

I am stuck at this point and I don't know how to proceed from here .

Thanks,
Shan
Mujeebur Rahman
Greenhorn

Joined: Jul 10, 2008
Posts: 20
Incidentally, I was trying to install Jadclipse on my RSA 7.5 just today. Here I have summerized the steps in brief
1. Download Jad.exe

from URL http://web.archive.org/web/20080214075546/http://www.kpdus.com/jad.html and unzip to C:\temp\download\jadnt158

2. Install via Eclipse Equinox
http://webobjects.mdimension.com/jadclipse/3.4

3. Preferences -- Genral -- Editors -- File Associations

.class with jadclipse

4. Preferences -- Java-- Jadclipse -- Path to decompiler -- edit with the path of jad.exe

example C:\temp\download\jadnt158\jad.exe

Thats it folks. Let me know did this help you ?
Shanmugam Muthukumarasamy
Ranch Hand

Joined: Jan 11, 2003
Posts: 83
Thanks everyone .

I figured out this issue. Here are the steps.

1. Download Jad.exe and extract the content to the desired folder.
example: C:\Jad
2. Download the Jadclipse plugin and keep that under C:\Program Files\IBM\SDP\plugins
3. Create the shortcut for RAD; Right click on the RAD short cut and select "properties"; On the "Target" add the -clean at the end as you see below
"C:\Program Files\IBM\SDP\eclipse.exe" -product com.ibm.rational.rad.product.v75.ide -clean
4. The clean command refreshes the recently added plugins to the RAD
5. Now go to "Windows->Preferences->Java->Jadclipse" and configure "Path to decompiler" to C:\Jad\jad.exe
6. Then go to "Windows->Preferences->Genral->Editors->File Associations, highlight ".class" and set the defaut option with jadclipse.

Hope this will work for other plugins too .

Shan
Mujeebur Rahman
Greenhorn

Joined: Jul 10, 2008
Posts: 20
Hi,

I will not say that the way you have installed Jadclipse plug-in in RAD 7.5 is wrong. The disadvantages you will feel when you distribute RAD installation, install in another location and during upgrade. One need to keep maintaining the list of plug-ins carefully . Updating them is involved with manual efforts.

The correct/approprite way of doing this via new automated mechanism (Equinox p2 Update) so your maintenance (update plug-in, distribue and upgrade RAD) becomes much more easy.

Regards,
Mujeebur Rahman
Shanmugam Muthukumarasamy
Ranch Hand

Joined: Jan 11, 2003
Posts: 83
Hi,

Thanks for sharing.

If I understand the purpose of "Equinox p2 Update" correctly, this provides the "Software Updates..." option under the Help menu.

If that is the case, I have installed other plugins in my RAD using that (Equinox p2 Update) option only.

Installing JADclipse is slightly different in my case, I could not add remote/local site to the JADclipse and I was prompted with error message "there is no update site" and hence I have to do the above steps I have explained already.

If you have tried installing Jadclipse with "Equinox p2 Update" option, can you share the specific details on that.

Thanks,
Shan
verduka fox
Ranch Hand

Joined: Jan 18, 2001
Posts: 178
I am trying to install Checkstyle from http://checkstyle.sourceforge.net/ in RAD 7.5.2 on Windows XP. I have tried following the advice listed earlier - open RAD 7.5.2, go to Help - Software Updates - Available Software. I then click Add Site. I have tried Local to the directory where the zip resides and Archive to the zip and to checkstyle-all-5.0.jar, but each time I get a message 'No repository found' and the Install button is disabled. I'd really like to get Checkstyle working from RAD 7.5.2. Can anyone advise me what I'm doing incorrectly? I appreciate your help.
Sonali Sabnis
Greenhorn

Joined: Aug 25, 2008
Posts: 20
Hi

Anybody knows about star team plugin for IBM RAD 7.5?

rahul mghare
Greenhorn

Joined: Jun 14, 2010
Posts: 1
Hi ,
I am trying to install maven plug in into RAD 7.5.0 ..
but it does not work
I followed these steps :-
1.extract manen zip into C:\RAD 7.5\IBM\SDP\plugins
2.set M2_home variable
3.set Path variable

but it is not working.

so please help me.
Ramesh Tumma
Greenhorn

Joined: Oct 12, 2009
Posts: 4
Rahul,

Can you please let me know the URL to download Maven2 plug in for RAD7.5. I know the update site only, http://m2eclipse.sonatype.org/sites/m2e. When i try to install Maven2 plugin using this site, i am receiving the following error.

No repository found at http://m2eclipse.sonatype.org/sites/m2e
Error reading update site http://m2eclipse.sonatype.org/sites/m2e.
Connection refused: connect

Do we need to change any settings in RAD7.5 or is it becuase of firewall protection. I am able to download anything in my network.Kindly anybody help me out
Dave Macpherson
Greenhorn

Joined: Jul 29, 2010
Posts: 1
Ramesh Tumma wrote:Rahul,

Can you please let me know the URL to download Maven2 plug in for RAD7.5. I know the update site only, http://m2eclipse.sonatype.org/sites/m2e. When i try to install Maven2 plugin using this site, i am receiving the following error.

No repository found at http://m2eclipse.sonatype.org/sites/m2e
Error reading update site http://m2eclipse.sonatype.org/sites/m2e.
Connection refused: connect

Do we need to change any settings in RAD7.5 or is it becuase of firewall protection. I am able to download anything in my network.Kindly anybody help me out


Ramesh

Were you able to install the m2eclipse plugin? I'm seeing the same behavior as you (no repository found message) and am pulling my hair out trying to get plugins installed in my RAD 7.5 environment?

Dave

*EDIT*

Never mind...found a solution. Use this site instead: http://m2eclipse.sonatype.org/sites/m2e-e34/

Dave
Martin Carlsen
Greenhorn

Joined: Aug 11, 2010
Posts: 6
I also had the problem Ramesh mentions.

I tried with http://m2eclipse.sonatype.org/sites/m2e-e34/ and then I didnt get the "no repository found message", so it seems to get installed.

However I don't get the Maven menu options in the SVN repository view. I.e. "Check out as Maven project".

Does anyone know why this works in eclipse, but not in RAD? Am I missing something?
Martin Carlsen
Greenhorn

Joined: Aug 11, 2010
Posts: 6
Martin Carlsen wrote:I also had the problem Ramesh mentions.

I tried with http://m2eclipse.sonatype.org/sites/m2e-e34/ and then I didnt get the "no repository found message", so it seems to get installed.

However I don't get the Maven menu options in the SVN repository view. I.e. "Check out as Maven project".

Does anyone know why this works in eclipse, but not in RAD? Am I missing something?


Figured it out. It is located in m2eclipse extras.
Yuming Liu
Greenhorn

Joined: Aug 24, 2010
Posts: 1
Martin:
The m2e-e34 site got away with the no repository issue. However, when "install", numerous dependencies are missing from the RAD7.5!
NUMEROUS!
Did you have the same problem? Or you have a different version of RAD?

Eclipse version for my RAD 7.5 is 3.4.2.

Thanks.
Manfred Schürhoff
Greenhorn

Joined: Apr 24, 2009
Posts: 6
Hi,

I was running into the same problem and found a solution. Check out this site: https://docs.sonatype.org/display/M2ECLIPSE/Installation+Requirements. Here you can read:

If you are using RAD/RSA 7.5, install the "Graphical Editing Framework Zest Visualization Toolkit" under the most recent version of "GEF SDK" using the update site http://download.eclipse.org/tools/gef/updates/releases/ before you install m2eclipse.

After installing the GEF plugin, restart RAD, then install m2eclipse plugin (only select the Required component).

If you still get some errors ("No repository found.....") when installing the m2eclipse plugin, check your proxy settings (if any).
It may also help to restart RAD again or to remove and then add the m2eclipse URL (http://m2eclipse.sonatype.org/sites/m2e-e34/) again.

This did the trick for me.

Regards,
Manfred



[Thumbnail for m2eclipse-install.jpg]


[Thumbnail for gef-plugin-install.jpg]

Nitin Virmani
Greenhorn

Joined: Mar 07, 2011
Posts: 1
Hi All,

I am trying to install the checkstyle plugin on RAD 7.5 but as soon as enter the site url: "http://eclipse-cs.sourceforge.net/update/" it says me "No updates found on the site. Please try another site."

Can someone please help me out in this issue if the url I am entering is incorrect. Please provide the correct url if anyone have. Thanks!

Nitin
Prashant Langade
Ranch Hand

Joined: Jul 01, 2009
Posts: 71
Hi

I want to install plugin for hbm file generation in RAD 7.5.

I tried following the steps menstioned at Hibernate Auto-generate hbm files

i.e download and extract the hibernate-tools.jar at plugins folder and restart RAD.
but i am unable to see File -> New -> Other -> Hibernate -> Hibernate Configuration File options..

Can any one please let me know how to install?

Thanks and Regards
Prashant

ketan salvi
Greenhorn

Joined: Aug 01, 2012
Posts: 4
Im trying to install subclipse 1.6.x in rad 7.5.5.3 but im not able to.The find and install option is not available so i tried doing software updates>available software>>add site local >> and provided the location where my subclipse extract is present .its throwing error saying
SVNKit Library will be ignored because a newer version is already installed
CollabNet Merge Client will be ignored because a newer version is already installed.
Cannot complete the request. See the details.
JNA Library will be ignored because a newer version is already installed.
Subversion Client Adapter (Required) will be ignored because a newer version is already installed.
Subversion JavaHL Native Library Adapter (Required) will be ignored because a newer version is already installed.
Subversion Revision Graph will be ignored because a newer version is already installed.
Cannot find a solution where both "org.tigris.subversion.subclipse.ui [1.6.5]" and "org.tigris.subversion.subclipse.ui 1.6.6" are satisfied.
Cannot find a solution where both "org.tigris.subversion.subclipse.core [1.6.5]" and "org.tigris.subversion.subclipse.core 1.6.6" are satisfied.
Unsatisfied dependency: [org.tigris.subversion.subclipse.mylyn.feature.group 3.0.0] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.team.ui/[3.0.0,4.0.0)
Unsatisfied dependency: [org.tigris.subversion.subclipse.mylyn.feature.group 3.0.0] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.tasks.ui/[3.0.0,4.0.0)
Unsatisfied dependency: [org.tigris.subversion.subclipse.mylyn.feature.group 3.0.0] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.mylyn.tasks.core/[3.0.0,4.0.0)
Unsatisfied dependency: [org.tigris.subversion.subclipse.mylyn 3.0.0] requiredCapability: osgi.bundle/org.eclipse.mylyn.tasks.core/[3.0.0,4.0.0)
Cannot find a solution where both "org.tigris.subversion.subclipse.ui [1.6.5]" and "org.tigris.subversion.subclipse.ui 1.6.6" are satisfied.
Cannot find a solution where both "org.tigris.subversion.subclipse.core [1.6.5]" and "org.tigris.subversion.subclipse.core 1.6.6" are satisfied.
Unsatisfied dependency: [org.tigris.subversion.subclipse.mylyn 3.0.0] requiredCapability: osgi.bundle/org.eclipse.mylyn.team.ui/[3.0.0,4.0.0)
I also tried extracting the subclipse 1.6.5 archive in c:/programfiles/ibm/sdp75 where my eclipse .exe is present but nothing happend ,then again i tried extracting subclipse_1.0.3.but im not getting subclipse in my rad
ketan salvi
Greenhorn

Joined: Aug 01, 2012
Posts: 4
Any help please?
Sai Rao
Greenhorn

Joined: Mar 23, 2007
Posts: 4

Manfred Schürhoff wrote:Hi,

I was running into the same problem and found a solution. Check out this site: https://docs.sonatype.org/display/M2ECLIPSE/Installation+Requirements. Here you can read:

If you are using RAD/RSA 7.5, install the "Graphical Editing Framework Zest Visualization Toolkit" under the most recent version of "GEF SDK" using the update site http://download.eclipse.org/tools/gef/updates/releases/ before you install m2eclipse.

After installing the GEF plugin, restart RAD, then install m2eclipse plugin (only select the Required component).

If you still get some errors ("No repository found.....") when installing the m2eclipse plugin, check your proxy settings (if any).
It may also help to restart RAD again or to remove and then add the m2eclipse URL (http://m2eclipse.sonatype.org/sites/m2e-e34/) again.

This did the trick for me.

Regards,
Manfred



Please note that the Zest toolkit appears to be no longer available at the link posted above, use instead https://hudson.eclipse.org/hudson/job/gef-master/lastSuccessfulBuild/artifact/update-site/ to install this update

Regards,
Sai Rao
ketan salvi
Greenhorn

Joined: Aug 01, 2012
Posts: 4
Thanks Sai Rao for the reply.But I ended up Uninstalling my rad and installing it again which solved the issue.
Sai Rao
Greenhorn

Joined: Mar 23, 2007
Posts: 4

An alternative to reinstalling RAD(that I consider a last resort brute force option) that worked for me (if it helps anyone else in a similar situation) was to revert the Software Update configuration in RAD - I used the following steps:
a> Navigate to Help->Software Updates->Installed Software tab , select the MAven install (if it appears ) and click Uninstall
b> Restart RAD when prompted
c>Navigate to Help->Software Updates, click 'Revert Configuration' button that appears on the right, select the target config date to revert to as the last known good config date prior to installing the Maven plugin

Now restart RAD and installthe Zest toolkit (https://hudson.eclipse.org/hudson/job/gef-master/lastSuccessfulBuild/artifact/update-site/)followed by the Maven plugin (http://m2eclipse.sonatype.org/sites/m2e-e34/) as described in previous posts

Hopefully it will save some time on the RAD reinstall for some.
Martin Vajsar
Sheriff

Joined: Aug 22, 2010
Posts: 3610
    
  60

salam rehman,
Your post was moved to a new topic.
 
GeeCON Prague 2014
 
subject: How to installa a plugin in RAD 7.5