aspose file tools*
The moose likes Cattle Drive and the fly likes No Class Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » This Site » Cattle Drive
Bookmark "No Class" Watch "No Class" New topic
Author

No Class

Ronald Schindler
Ranch Hand

Joined: Jul 11, 2000
Posts: 50
Okay, so I should probably know this but here's the situation.
I was happily compiling code last week. I began looking at Servlets and playing around with the WebLogic Server I have running on my laptop. I needed to send in one of the OOP assignments that was ready. I went to compile and review it before sending it and received this error when I tried to run it:
Exception in thread "main" java.lang.NoclassDefFound Error: classname
I didn't change the classpath. I have even compiled and tried running the program using full path names. Nothing is working. I searched the archives but didn't see a definitive answer. Anyone have any ideas?
Carol Murphy
village idiot
Bartender

Joined: Mar 15, 2001
Posts: 1195
Classpath, why did it have to Classpath? I can't escape from classpath!!!
Marilyn de Queiroz
Sheriff

Joined: Jul 22, 2000
Posts: 9046
    
  10
Originally posted by Ronald Schindler:
I didn't change the classpath.

You didn't change the classpath. Have you installed any new applications lately (maybe you installed WebLogic Server recently)? Sometimes apps change the classpath for you.


JavaBeginnersFaq
"Yesterday is history, tomorrow is a mystery, and today is a gift; that's why they call it the present." Eleanor Roosevelt
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: No Class