aspose file tools*
The moose likes Object Relational Mapping and the fly likes Problem with querying and one to many relationship.. Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Java 8 in Action this week in the Java 8 forum!
JavaRanch » Java Forums » Databases » Object Relational Mapping
Bookmark "Problem with querying and one to many relationship.." Watch "Problem with querying and one to many relationship.." New topic
Author

Problem with querying and one to many relationship..

Annie Jones
Greenhorn

Joined: Nov 05, 2007
Posts: 10
Hi,

I have the following mappings in my hibernate hbm.xml file (this cannot be changed, the table structure has been decided by the DBA):


We are passing these Postcode objects through to struts instead of having data transfer objects, this is read only data - the application will never modify any postcode/suburb information.

My problem is that I need a query that gives the same result as the following two queries:

but instead of returning Suburb objects and Postcode objects, only returns Postcode objects. As you can see, the first query will return Suburb objects as I am searching on the nzTownCity or nzSuburb columns because the suburbRequiredFlag is set to 'Y' on the Postcode.

I know this seems fairly complicated but if there is a way that I can get only Postcode objects with the matching Suburb objects (instead of all the Suburb objects that are bound to a Postcode because of the one-to-many relationship) then that would be great.

Thanks in advance,
Annie



Abraham Gimeno
Greenhorn

Joined: Jul 16, 2008
Posts: 7
I don't know if I understood well but, have you tried



and since it's ManyToOne you should be able to access Postcode object

 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Problem with querying and one to many relationship..
 
Similar Threads
problem creating a foreignkey relation in compositekeys
Hibernate Issue
Part of Composite-Id is foreign Key:How specify in Mapping?
Hibernate Batch with <join>
Getting an error when trying to insert data