File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Websphere and the fly likes Not able to config the database! Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Websphere
Bookmark "Not able to config the database!" Watch "Not able to config the database!" New topic
Author

Not able to config the database!

Rahuul Dravid
Ranch Hand

Joined: Feb 17, 2009
Posts: 42
Hi guys,
I am trying to config DB2 with my was v6 ..... and tried a couple of times... but not able to succeed !

I tried to even do it following a couple of tutorials...but with no luck so far .... so help me out guys.
I am getting the below error massage when i'm trying to test the connection for the datasource .... and my database username and password are correct to my knowledge ..... i even has a seperate account created for the database copy .. "db2admin" and i am able to login into that using the password .. which i have provided over there in the data source config

Test connection failed for data source DB2 Universal JDBC Driver DataSource on server server1 at node rakeshNode01 with the following exception: java.lang.Exception: java.sql.SQLException: [jcc][t4][2057][11264][3.50.152] The application server rejected establishment of the connection. An attempt was made to access a database, db2, which was either not found or does not support transactions. ERRORCODE=-4499, SQLSTATE=08004DSRA0010E: SQL State = 08004, Error Code = -4,499. View JVM logs for further details.


Can any one help me where i'm going worng .... i have been breaking trying with no much luck!!
Thanks in advance
Peace!!

Cameron Wallace McKenzie
author and cow tipper
Saloon Keeper

Joined: Aug 26, 2006
Posts: 4968
    
    1

Are db2 and WebSphere installed on the same machine, or are they separate?

Which driver type are you using?

There is an option for XA level on the JDBC provider, or DataSource connection page. Are you using the XA driver? Hmmmm....XA usually implies transactions. Maybe trying the non-XA driver. I only say that because of the reference to transactions in your error message.

All IBM tells us is that this code means the client cannot establish a connection to the database:

SQLSTATE Error Codes and their Explanations from IBM/DB2

Anything else you can tell us about the connection? Is it authenticated? Are you providing a username and password? I'd hate to go down the username/password path, because if that's wrong, you usually get a pretty good error message on just that exact point. This isn't really pointing to credentials.

-Cameron McKenzie

Rahuul Dravid
Ranch Hand

Joined: Feb 17, 2009
Posts: 42
Yes they both are on the same machine and.... wasv6.0.0.1 is my application server is that a know error ... do i need to apply some fixpack or refresh pack foe this to be solved..... ???

Well i am using the default username db2admin and that password for authentication purpose.... which wo;t be wrong.. as i can log into thath account perfectly!
And yes i choose the non-XA option ... connection pool option while configuring the JDBC driver... i guess .. the drivers is type 4 for DB2 V9 i just gave the path of thath particular java folder which has the db2jcc.jar , db2lic jarfiles which is need in order to connect to the data base !

I am still having no luck with that .. do i need to do something... specifically... in order to config this correctly .... i am liitle bit lost here... i read a couple of articles all point in the same way .. and i see nothing worng with way i have done ... except i am not able to connect to database

DO i have to upgrade my was to v6.0.2.31 ..... will that slove the problem ...... i read some thing like.. that .... i would really apprecite if some one corrects me .. if i am going in the worng direction !
Thanks in advance!
Peace
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Not able to config the database!