aspose file tools*
The moose likes BEA/Weblogic and the fly likes security services Unavailable Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "security services Unavailable" Watch "security services Unavailable" New topic
Author

security services Unavailable

Shyam Hai
Ranch Hand

Joined: Feb 04, 2009
Posts: 68


When i start the weblogic server8.1
that time i get this error

"weblogic.security.service.SecurityServiceRuntimeException:[Security:090399] security services Unavailable"

how to rectify this error.
Please...
thrilochan prasad
Greenhorn

Joined: Oct 03, 2008
Posts: 12
hi

did you created any security realms.if it is wrongly created it shows this type of message.

try to start the default domain which comes with weblogic server installation.


thanks
thrilochan
arun sweet
Greenhorn

Joined: Apr 29, 2011
Posts: 1

Hi,

Facing same issue..

Did we have an solution for this >?

thanks
arun
anandraj tadkal
Ranch Hand

Joined: Feb 22, 2011
Posts: 98

Before the server starts up, it would initialize its security realm.

Weblogic server by default comes with a security realm called 'MyRealm'.

Could you confirm whether you are using the default security realm or any customized security realm?

This error occurs due to failure of any security services.

Regards,
Anandraj
http://weblogic-wonders.com/


Regards,
Anandraj
http://weblogic-wonders.com
Follow us on facebook:
https://www.facebook.com/weblogicwonders
thiyagarajan chandru
Greenhorn

Joined: Sep 07, 2011
Posts: 1
Hi,
I am using weblogic 10.3.5.0 in HP-UX. I am also facing the same error.

"<Sep 7, 2011 4:27:18 PM IST> <Error> <Security> <BEA-090870> <The realm "myrealm" failed to be loaded: weblogic.security.service.SecurityServiceException: com.bea.common.engine.ServiceInitializationException: weblogic.security.spi.ProviderInitializationException: A failure occurred attempting to load LDIF for provider Authorizer from file /app/oracle/product/Middleware/wlserver_10.3/server/lib/XACMLAuthorizerInit.ldift.."


But i am trying to start my default admin server.

My configuration is below,

My Configuration is

Operating System ->HP-UX 11.3
Weblogic version->10.3.5.0
Configuration->1 machine,1 managed server,1 admin server.

Machine contains the managed server and admin server. I configure everthing in there default port only.

I am starting the node manager first and then i m starting the startweblogic.sh. But it throw the error like above. and the server get shutdown.
Please help me to solve this issue.
 
 
subject: security services Unavailable