aspose file tools*
The moose likes JBoss/WildFly and the fly likes problem with .jar files deployment Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "problem with .jar files deployment" Watch "problem with .jar files deployment" New topic
Author

problem with .jar files deployment

amit daundkar
Ranch Hand

Joined: Jan 24, 2009
Posts: 47
hello,
i am using Jboss-5.1.0-CR1 on linux fc9. The database is MySQL.
i have deployed the .war file in the /server/default/deploy directory.
i have also added the required jar files(commons-logging.jar, dwr.jar, mysql-connector.jar) in the /server/default/lib directory.

when i start JBoss as, i can see the module deployed.
the index page, and Login page also displays.
but when i give a request for a page that requires database connectivity,
i get a 404- resource not found error.

i think this is an issue regarding the .jar files deployment.
Do i need to copy these three files in any other directory also?
the server.log file also doesnt show anything.

what may be the reason? .

please reply. i am in need.
thank you.
Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 10112
    
165

How do you start the server? What command do you use? And what URL do you use to access the application from the browser? Can you please post the last few lines from the logs that you see on the console when you start the AS?

While posting logs or xml content or code, please remember to wrap it in a code block by using the Code button in the message editor window. Please use the Preview button to ensure that your post is correctly formatted.


[My Blog] [JavaRanch Journal]
amit daundkar
Ranch Hand

Joined: Jan 24, 2009
Posts: 47
Jaikiran Pai wrote:How do you start the server? What command do you use? And what URL do you use to access the application from the browser? Can you please post the last few lines from the logs that you see on the console when you start the AS?

While posting logs or xml content or code, please remember to wrap it in a code block by using the Code button in the message editor window. Please use the Preview button to ensure that your post is correctly formatted.


hello Jaikiran,
thank you for replying.
i start the server with run .sh in /JBoss/bin. and the last few lines when the server starts are..


BhaginiBank is the application (war deployed).
and the same application runs fine in glassfish V2. that is why i am confused. i mean the same page in glassfish shall run in JBoss also, right?
anyway,
thank you.
Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 10112
    
165

Please post the error that you see. You did not mention the URL that you use to access the application. Looking at the logs, its available at http://localhost:8080/BhaginiBank. Are you accessing the application from the same machine where the server is running?

amit daundkar
Ranch Hand

Joined: Jan 24, 2009
Posts: 47
hello Jaikiran,
the problem is solved.
i created another .war file and deployed it again.
and it is working fine now. but its an unknown success.
anyway,
thank you very much for your help.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: problem with .jar files deployment