wood burning stoves 2.0*
The moose likes Websphere and the fly likes Migrate Struts 1.1 from WebSphere 5.1 to 6.1 - JSP container failed to load TagExtraInfo Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark "Migrate Struts 1.1 from WebSphere 5.1 to 6.1 - JSP container failed to load TagExtraInfo " Watch "Migrate Struts 1.1 from WebSphere 5.1 to 6.1 - JSP container failed to load TagExtraInfo " New topic
Author

Migrate Struts 1.1 from WebSphere 5.1 to 6.1 - JSP container failed to load TagExtraInfo

Sam Gehouse
Ranch Hand

Joined: Jul 21, 2003
Posts: 281
I am trying to migrate Struts 1.1 application from WebSphere 5.1 to WebSphere 6.1. After successfully deploying Struts 1.1 app in WebSphere 6.1 server, I start the 6.1 server. I get the following error in server log as:

com.ibm.ws.jsp.taglib.TldParser logParseErrorMessage Failed to parse Tag Library [/WEB-INF/conf/struts.tld]: JSPG0235E: The JSP container failed to load the TagExtraInfo class http://org.apache.struts.taglib.EnumerateTei

I get similar errors for IterateTei and TextTei

Will appreciate your response on:

1. Could you please show an example of what exact changes that need to be made in both struts.tld and web.xml?
2. Instead of making the changes in both struts.tld and web.xml, what exact parameter needs to be added in WAS 6.1 server?

Thanks for your time in advance.

I found similar posting in IBM forum as:
http://www.ibm.com/developerworks/forums/thread.jspa?threadID=179489&tstart=0

But the answer was not clear.
 
jQuery in Action, 2nd edition
 
subject: Migrate Struts 1.1 from WebSphere 5.1 to 6.1 - JSP container failed to load TagExtraInfo
 
Similar Threads
Difference Between Struts 1.0 and Struts 1.1
Migrate Struts 1.0 app from WebSphere 5.1 to 6.1 - JSP container failed to load the TagExtraInfo
WAS 6 in RAD does not load struts tld
Problem during migration from Websphere 5.1 to Websphere 6.1
RSA- TagExtraInfo class problem