wood burning stoves 2.0*
The moose likes JSF and the fly likes JSF CommandButton issue while sending Email  Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of The Java EE 7 Tutorial Volume 1 or Volume 2 this week in the Java EE forum
or jQuery UI in Action in the JavaScript forum!
JavaRanch » Java Forums » Java » JSF
Bookmark "JSF CommandButton issue while sending Email  " Watch "JSF CommandButton issue while sending Email  " New topic
Author

JSF CommandButton issue while sending Email

vijay k vemula
Greenhorn

Joined: Dec 17, 2008
Posts: 10
Hi All,

First of all i would like to thank you all for your previous valuable suggestions. Currently i am working on a JSF application where we have email functionality in our application.

We have provided 2 options to the user, a mail with attachment or mail without attachment. If user sends a mail without attachment everything works fine and hence no issues. Once the mail is sent, he will be taken to Email confirm page where he will have 'Ok' button.

The problem i am facing is when email is sent with attachment. When the user sends an email with attachment, mail was sent successfully and he was taken to email confirm page. But the user has to click 'Ok' button twice which is really weird.

Here is my sample code

<h:panelGrid id="emailConfirmGrid" columns="1">
<hutputText id="confirmMsg" value="#{CommonLabels['EmailConfirm.ConfirmMessage']}"/>
<t:commandButton id="okBtn" value="#{CommonLabels['EmailConfirm.Ok']}" action="# bean.invokeRequestedView}" immediate="true" />
</h:panelGrid>


Even i tried putting immediate="true" for my 'Ok' command button still not working.

Any help will be highly appreciated.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: JSF CommandButton issue while sending Email