This week's book giveaway is in the Clojure forum.
We're giving away four copies of Clojure in Action and have Amit Rathore and Francis Avila on-line!
See this thread for details.
Win a copy of Clojure in Action this week in the Clojure forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Problem in Configuring MySQL

 
Mark Henryson
Ranch Hand
Posts: 200
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am using Windows Vista Home Basic with Norton Internet Security 2009.
My Windows firewall has been turned off by norton, as it provides its own firewall.
I have installed mysql and I am trying to configure my mysql 5.1.
While configuring at the last step "Applying Security setting" mysql throws an error saying that to "open the port 3306 TCP and retry".
As my windows firewall has been turned off my norton, I have gone to the norton internet setting and in program control I have seen for mysql the firewall option is already "Auto" with "Allow" option for port 53.
I have added the port 3306 (local port) with TCP. Then I have tried to configure, but still getting the same error message.
I have also added the port to exclude from firewall in windows firewall also. But the result is the same.
Please suggest what needs to be done for it.
Configuring the MySQL in Windows Vista with Norton Internet Security 2009.
 
Deepak Bala
Bartender
Posts: 6663
5
Firefox Browser Linux MyEclipse IDE
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Not used mysql myself but I can relate with the firewall problem thing so here goes.

Log off the internet. Bring down the windows and norton firewall and try installing the database. If you are able to then you can confirm that either windows or norton was the culprit. Check your norton logs to check what is going on as well
 
Campbell Ritchie
Sheriff
Pie
Posts: 47253
52
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
That sounds a good idea, Deepak Bala, but I would suggest as well: turn your router/modem off at the mains until you have finished the whole procedure, and enable your firewalls again before turning the modem/router on.
 
Mark Henryson
Ranch Hand
Posts: 200
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I will try this and let you know.
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic