Win a copy of Re-engineering Legacy Software this week in the Refactoring forum
or Docker in Action in the Cloud/Virtualization forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

c set not working with JSTL1.0

 
Sachin Agarwalla
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello All

I am facing a very complicated problem where I am not able to use the <c:set> action in my JSP file.

I have the following piece of lines in my JSP file:


The cut and c:if actions behaves fine but when I add the c:set action i get the error as this:
Unexpected error: javax.servlet.ServletException: javax.servlet.jsp.JspException: ServletException in '/jsp/fpgLayout.jsp': javax/servlet/jsp/el/VariableResolver

I am using JSP1.2 and Tomcat 4. I have also added the 2 jars required for JSTL in WEB-INF/lib.

Please do let me know where I go wrong or what is to be done.

Thanks
Sachin

 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Are you *sure* you're not mixing JSTL/JEE versions?
 
Bear Bibeault
Author and ninkuma
Marshal
Pie
Posts: 64633
86
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Please take the time to choose the correct forum for your posts. This forum is for questions on Servlets.

For more information, please read this.

This post has been moved to a more appropriate forum.

 
Sachin Agarwalla
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi David

What do you mean by mixing JSTL/JEE versions
 
Bear Bibeault
Author and ninkuma
Marshal
Pie
Posts: 64633
86
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Do you have a copy of servlet-api.jar or jsp-api.jar in your WEB-INF/lib?

If so, get rid of them!

That can cause this problem.
 
Seetharaman Venkatasamy
Ranch Hand
Posts: 5575
Eclipse IDE Java Windows XP
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Sachin Agarwalla wrote:What do you mean by mixing JSTL/JEE versions


Check this
 
Seetharaman Venkatasamy
Ranch Hand
Posts: 5575
Eclipse IDE Java Windows XP
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Bear Bibeault wrote:Do you have a copy of servlet-api.jar or jsp-api.jar in your WEB-INF/lib?
If so, get rid of them!


youuu
 
Sachin Agarwalla
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Bear i don't have the jars as mentioned by you.
Seetharam, the link that you provided http://faq.javaranch.com/java/ServletsWebXml doesn't mention about what should the web.xml be for Servlet 2.3
 
Seetharaman Venkatasamy
Ranch Hand
Posts: 5575
Eclipse IDE Java Windows XP
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
can you post your web.xml ?
 
Sachin Agarwalla
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
My web.xml -


 
Seetharaman Venkatasamy
Ranch Hand
Posts: 5575
Eclipse IDE Java Windows XP
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
you have correct we.xml version for Servlet 2.3 . and also you should use jsp1.x version
 
Seetharaman Venkatasamy
Ranch Hand
Posts: 5575
Eclipse IDE Java Windows XP
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
you have correct web.xml version for Servlet 2.3 . and also you should use jsp1.x version
 
Sachin Agarwalla
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yes i am using servlet 2.3 and JSP is 1.2 only and I am using JSTL 1.0.
I am really very confused as to why all core tags are working fine and not the <c:set> .
I am also getting one error in my console like this:

Any idea how can i resolve this.
I don't need to add any tld right.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic