aspose file tools*
The moose likes GWT and the fly likes GWT Ext CardLayout Not Displayng form Widgets and Components Properly - Just Not Working! Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Soft Skills this week in the Jobs Discussion forum!
JavaRanch » Java Forums » Frameworks » GWT
Bookmark "GWT Ext CardLayout Not Displayng form Widgets and Components Properly - Just Not Working!" Watch "GWT Ext CardLayout Not Displayng form Widgets and Components Properly - Just Not Working!" New topic
Author

GWT Ext CardLayout Not Displayng form Widgets and Components Properly - Just Not Working!

Cameron Wallace McKenzie
author and cow tipper
Saloon Keeper

Joined: Aug 26, 2006
Posts: 4968
    
    1

So, my Google Web Toolkit Ext application was working fine, but as soon as I nested some CardLayouts, or added containers to my CardLayout (JavaDoc) panel, various components would not render or show up, and other widgets like radio or checkboxes, and even TestFields, would be all messed up in their layout.

At one point, I found that if I minimized/maximized and restored the web page, the components would show up. That allowed me to test for a day, but I decided I needed to really fix it. When I fixed it, nothing would show up at all!

The following post indicated that I'm not alone, and some solutions have been proposed:

Possible Solutions to GWT CardLayout Display Problems

I must say, the suggestion to set the HideMode to 'offsets' didn't work for me.




I used the following code after adding panels to the CardLayout, and it provided me some intermittent relief, but I was wondering if there was any more stable solutions to the problem, other than just going with a normal GWT DeckPanel (JavaDoc) ? Personally, I'd prefer not to mix Google Web Toolkit and GWT-Ext components.



-Cameron McKenzie




 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: GWT Ext CardLayout Not Displayng form Widgets and Components Properly - Just Not Working!