Meaningless Drivel is fun!*
The moose likes Web Services and the fly likes JAXB Problem - Need Help Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Web Services
Bookmark "JAXB Problem - Need Help" Watch "JAXB Problem - Need Help" New topic
Author

JAXB Problem - Need Help

Muks Sam
Ranch Hand

Joined: Apr 09, 2004
Posts: 47

Hi,

I am using ANT 1.6, JAXB 2.0. jdk1.5.0_19.

While binding the XSD and exploding the XSD, I got below mentioned problem as in figure.

The problem is, after running the ant script, the buildfile should generate the classes and interfaces pertaining to xsd. the ant is generating only classes and not interfaces and /impl classes and folders etc.

Can somebody help me in resoving what exactly is the problem?


Thanks in advance,

- Muks



[Thumbnail for 1.JPG]

Ivan Krizsan
Ranch Hand

Joined: Oct 04, 2006
Posts: 2198
    
    1
Hi!
It looks like you do not have the XJC Ant task defined properly.
Check the following references for more information:
https://jaxb.dev.java.net/nonav/2.1.9/docs/xjcTask.html
https://jaxb.dev.java.net/nonav/2.1.9/docs/xjc.html
Best wishes!
Muks Sam
Ranch Hand

Joined: Apr 09, 2004
Posts: 47

Hi Ivan.

Thanks for ton,

Correct, You identified the problem. only difference was i could identify the problem little early, I wish I had this answer before.

Neverthless, this definitely helped again to remember,

Thanks again

- M
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
 
subject: JAXB Problem - Need Help
 
Similar Threads
Jaxb inside WSAD 5.1
JAXB 2.0 binding Problem - Need Some help
JAXB Problem...Any help ??
Java Migration from 1.4 to 1.6
Ant Build Problem