aspose file tools*
The moose likes Java Micro Edition and the fly likes Runniny standard J2ME middlets on blackberry emulator Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Mobile » Java Micro Edition
Bookmark "Runniny standard J2ME middlets on blackberry emulator" Watch "Runniny standard J2ME middlets on blackberry emulator" New topic
Author

Runniny standard J2ME middlets on blackberry emulator

Nrapendra Sharma
Ranch Hand

Joined: Jun 16, 2008
Posts: 31
Hi,
I have developed a J2ME app which is running fine on Nokia and sony erricson phones. When installing same app on blackberry i m getting error 907 invalid jar.
can anyone tell me why this is coming... ???

Also i have setup development enviroment for Blackberry.. but i am unable to run standard J2ME middlets on blackberry emulator.

How can i run middlet on blackberry emulator ???


Regards,
Nrapendra Sharma
Elías Turbay
Ranch Hand

Joined: Oct 06, 2005
Posts: 35
Hi, you need to convert your MIDlet first:

C:\Program Files (x86)\Research In Motion\BlackBerry JDE 4.6.0\bin>rapc import="C:\Program Files (x86)\Research In Motion\BlackBerry JDE 4.6.0\lib\net_rim_api.jar" codename="C:\BBMidlet" -midlet "C:\xxx.jad" "C:\xxx.jar"

You will get a file named "BBMidlet.cod" ... Then use the option "Load Java Program" from BB Emulator

That's all

If you want to emulate networking operations, you need to install the "BlackBerry Email and MDS Services Simulators 4.1.2" as well.

(Sorry for my poor English)
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Runniny standard J2ME middlets on blackberry emulator