wood burning stoves 2.0*
The moose likes Tomcat and the fly likes TOMCAT Not working Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Products » Tomcat
Bookmark "TOMCAT Not working" Watch "TOMCAT Not working" New topic
Author

TOMCAT Not working

prathamesh bandivadekar
Ranch Hand

Joined: May 22, 2008
Posts: 43
My prb is as follows:

I have one windows machine with java 1.4 and tomcat 4.0 on it. Now i want to practice struts on it.

So i installed Tomcat 6.0 and jdk 1.5. But now when i try to run a command startup.bat on my wrkstation it gives followiing error. Nothing has been changed except the insstallation.

The prb statment is as follows :
Jun 8, 2009 3:25:39 PM org.apache.catalina.core.AprLifecycleListener init
INFO: The Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\Program Files\Java\jdk1.5.0_06\bin;.;C:\WINDOWS\system32;C:\WINDOWS;C:\Program Files\Microsoft SQL Server\80\Tools\binn\;C:\apache-ant-1.6.2\bin;C:\j2sdk1.4.2_06\bin;c:\Program Files\Microsoft SQL Server\90\Tools\binn\;C:\WINDOWS\system32\WindowsPowerShell\v1.0
Jun 8, 2009 3:25:39 PM org.apache.coyote.http11.Http11Protocol init
SEVERE: Error initializing endpoint
java.net.BindException: Address already in use: JVM_Bind:80
at org.apache.tomcat.util.net.JIoEndpoint.init(JIoEndpoint.java:499)
at org.apache.coyote.http11.Http11Protocol.init(Http11Protocol.java:175)
at org.apache.catalina.connector.Connector.initialize(Connector.java:1059)
at org.apache.catalina.core.StandardService.initialize(StandardService.java:578)
at org.apache.catalina.core.StandardServer.initialize(StandardServer.java:792)
at org.apache.catalina.startup.Catalina.load(Catalina.java:504)
at org.apache.catalina.startup.Catalina.load(Catalina.java:524)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:260)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:412)
Jun 8, 2009 3:25:39 PM org.apache.catalina.startup.Catalina load
SEVERE: Catalina.start
LifecycleException: Protocol handler initialization failed: java.net.BindException: Address already in use: JVM_Bind:80
at org.apache.catalina.connector.Connector.initialize(Connector.java:1061)
at org.apache.catalina.core.StandardService.initialize(StandardService.java:578)
at org.apache.catalina.core.StandardServer.initialize(StandardServer.java:792)
at org.apache.catalina.startup.Catalina.load(Catalina.java:504)
at org.apache.catalina.startup.Catalina.load(Catalina.java:524)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:260)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:412)
Jun 8, 2009 3:25:39 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 594 ms

Thanks in advance!!!
Pratham.


Prathamesh M.B.<br />Java....only.....
Ulf Dittmer
Marshal

Joined: Mar 22, 2005
Posts: 41054
    
  43
java.net.BindException: Address already in use: JVM_Bind:80

Something is running on port 80 already; maybe the existing Tomcat 4? You need to turn that off first (or use a different port for Tomcat 6).


Ping & DNS - my free Android networking tools app
prathamesh bandivadekar
Ranch Hand

Joined: May 22, 2008
Posts: 43
Thanks Ulf Sir!!!
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: TOMCAT Not working
 
Similar Threads
apache tomcat 6.0.14 not starting
java.net.SocketException: Permission denied: listen failed
Tomcat fails to restart with "Address already in use" exception
Two tomcat windows on clicking startup.bat
ANT and Eclipse "Java Build Path"