aspose file tools*
The moose likes Websphere and the fly likes java.lang.NoClassDefFoundError:  error when try to start websphere server Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark "java.lang.NoClassDefFoundError:  error when try to start websphere server" Watch "java.lang.NoClassDefFoundError:  error when try to start websphere server" New topic
Author

java.lang.NoClassDefFoundError: error when try to start websphere server

priya pillai
Ranch Hand

Joined: Sep 12, 2007
Posts: 57
Hi friends,
I installed WSApplication server 6.When I try to start the server using eclipse i am getting error of

java.lang.NoClassDefFoundError: Files/IBM/WebSphere/AppServer/java/jre/lib/ext/ibmorb/jar;C:/Program
Caused by: java.lang.ClassNotFoundException: Files.IBM.WebSphere.AppServer.java.jre.lib.ext.ibmorb.jar;C:.Program
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClassInternal(Unknown Source)
Exception in thread "main"


When I googled i found the soluton to this is

The "telling" thing about this error message is the fact that the text immediately after the NoClassDefFoundError is "Files/IBM/". This looks like you have a space in your classpath (i.e., "C:\Program Files\...")

You probably need to surround the directories that have a space in the name with double quotes.

In my case also i have one space between
java.lang.NoClassDefFoundError: Files/IBM/WebSphere/AppServer/java/jre/lib/ext/ibmorb/jar;

If the space is the problem how to remove the space....or sapce is not the problem then how to resolve this?

Please help

Thanks in advance

Regards
Priya
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: java.lang.NoClassDefFoundError: error when try to start websphere server
 
Similar Threads
How to use Eclipe with WebSphere6.1 or WebLogic 10
How to integrate eclpse and Websphere Application server 6.0
Starting Websphere 6.0 in Eclipse3.3
Error: Integration of Websphere Application Server V 6.0 in Eclipse 3.4 or MyEclipse
WSAD Websphere without WSAD??!?!