This week's book giveaway is in the OO, Patterns, UML and Refactoring forum.
We're giving away four copies of Refactoring for Software Design Smells: Managing Technical Debt and have Girish Suryanarayana, Ganesh Samarthyam & Tushar Sharma on-line!
See this thread for details.
The moose likes Swing / AWT / SWT and the fly likes RTFEditorKit - underline not working Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Java » Swing / AWT / SWT
Bookmark "RTFEditorKit - underline not working" Watch "RTFEditorKit - underline not working" New topic
Author

RTFEditorKit - underline not working

chris gar
Ranch Hand

Joined: Jul 20, 2002
Posts: 45
I'm using RTFEditorKit to read rtf files and display on reports. I know the kit it typically used for GUI - but I'm not sure else how to read and display rtf files. I'm reading the rtf files and displaying the text on reports via Jasper reports.

Underline, bold and italic text is not recognized. the actual text prints, but the style is not included. I can see control characters like /ul and when I print the Abstract document it shows up.




but for some reason it wont display on the output.


a.) Does anyone know how I can get the styles to work?

b.) Is there a better way to go about this?

Thanks
 
I’ve looked at a lot of different solutions, and in my humble opinion Aspose is the way to go. Here’s the link: http://aspose.com
 
subject: RTFEditorKit - underline not working
 
It's not a secret anymore!