File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes IDEs, Version Control and other tools and the fly likes Eclipse 3.4 compilation problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "Eclipse 3.4 compilation problem" Watch "Eclipse 3.4 compilation problem" New topic
Author

Eclipse 3.4 compilation problem

Sujatha Kalluri
Ranch Hand

Joined: Oct 09, 2002
Posts: 33
Hi,

I am using Eclipse 3.4.2 with Tomcat 6.0, my project is showing the compilation problems like".... cannot be resolved to a type"
basically the jsp files are not able to resolve the import statements which has reference to src folders. I didn't see this problem in Eclipse 3.2, is it compilation bug in Eclipse 3.4 version, anybody faced it, how to resolve this.

thanks,
Sujatha.
Tim Holloway
Saloon Keeper

Joined: Jun 25, 2001
Posts: 16305
    
  21

It might be related to some really bad bugs in the XML/HTML editor that shipped as part of the original Ganymede. Try updating Eclipse and see if the problem goes away.


Customer surveys are for companies who didn't pay proper attention to begin with.
Lars Vogel
Ranch Hand

Joined: Oct 10, 2007
Posts: 55
Difficult to answer based on your description. You may want to use this tutorial to get a detailed step-by-step description: JSP and Servlet development with Eclipse - Tutorial


Tutorials about Java, Eclipse and Webprogramming http://www.vogella.de
 
 
subject: Eclipse 3.4 compilation problem