This week's book giveaway is in the Java 8 forum.
We're giving away four copies of Java 8 in Action and have Raoul-Gabriel Urma, Mario Fusco, and Alan Mycroft on-line!
See this thread for details.
The moose likes Ruby and the fly likes ERROR:  Error installing mongrel Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Java 8 in Action this week in the Java 8 forum!
JavaRanch » Java Forums » Languages » Ruby
Bookmark "ERROR:  Error installing mongrel" Watch "ERROR:  Error installing mongrel" New topic
Author

ERROR: Error installing mongrel

Ritesh Pareek
Ranch Hand

Joined: Nov 04, 2008
Posts: 50
Hi all,

I am getting some problem while installing mongrel on GoDaddy server.

Env is ::


[root@ip-97-74-86-181 bin]# gem environment
RubyGems Environment:
- RUBYGEMS VERSION: 1.3.4
- RUBY VERSION: 1.8.6 (2008-03-03 patchlevel 114) [i386-linux]
- INSTALLATION DIRECTORY: /usr/lib/ruby/gems/1.8
- RUBY EXECUTABLE: /usr/bin/ruby
- EXECUTABLE DIRECTORY: /usr/bin
- RUBYGEMS PLATFORMS:
- ruby
- x86-linux
- GEM PATHS:
- /usr/lib/ruby/gems/1.8
- /root/.gem/ruby/1.8
- GEM CONFIGURATION:
- :update_sources => true
- :verbose => true
- :benchmark => false
- :backtrace => false
- :bulk_threshold => 1000
- REMOTE SOURCES:
- http://gems.rubyforge.org/

While installing mongrel i am getting ::

[root@ip-97-74-86-181 bin]# gem install mongrel
Building native extensions. This could take a while...
ERROR: Error installing mongrel:
ERROR: Failed to build gem native extension.

/usr/bin/ruby extconf.rb
can't find header files for ruby.


Gem files will remain installed in /usr/lib/ruby/gems/1.8/gems/fastthread-1.0.7 for inspection.
Results logged to /usr/lib/ruby/gems/1.8/gems/fastthread-1.0.7/ext/fastthread/gem_make.out
[root@ip-97-74-86-181 bin]#

And the gems list is::

[root@ip-97-74-86-181 bin]# gem list --local

*** LOCAL GEMS ***

actionmailer (2.3.2)
actionpack (2.3.2)
activemerchant (1.4.2)
activerecord (2.3.2)
activerecord-jdbc-adapter (0.9.1)
activerecord-jdbcmysql-adapter (0.9.1)
activeresource (2.3.2)
activesupport (2.3.2)
builder (2.1.2)
calendar_date_select (1.15)
cgi_multipart_eof_fix (2.5.0)
daemons (1.0.10)
gem_plugin (0.2.3)
google-geocode (1.2.1)
hoe (2.2.0)
jdbc-mysql (5.0.4)
money (2.1.3)
rails (2.3.2)
rake (0.8.7)
rc-rest (2.2.1)
rubyforge (1.0.3)
rubygems-update (1.3.4)
sources (0.0.1)
ZenTest (4.1.1)

Please let me know where i am wrong. Thanks in advance.

Thanks

Ritesh Pareek
Ritesh Pareek
Ranch Hand

Joined: Nov 04, 2008
Posts: 50
Hi all,

I have fixed this. This error was not of mongrel, actually on feddora when we installl ruby package, it installed base ruby not ruby-deval package. I fixed it by

yum install ruby-deval

end well all well.


Thanks all
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: ERROR: Error installing mongrel
 
Similar Threads
Ruby 1.8 and MySql problem
Ruby on Rails question: yaml problem with scaffold generation
gem installation error
Fed Up Installing Rails.... How Do I Get Rid Of The Dependencies?
ruby script/server is not working