This week's book giveaway is in the Big Data forum.
We're giving away four copies of Elasticsearch in Action and have Radu Gheorghe & Matthew Lee Hinman on-line!
See this thread for details.
The moose likes Portals and Portlets and the fly likes How to disable portlet caching in JSR168 portlets? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Elasticsearch in Action this week in the Big Data forum!
JavaRanch » Java Forums » Java » Portals and Portlets
Bookmark "How to disable portlet caching in JSR168 portlets?" Watch "How to disable portlet caching in JSR168 portlets?" New topic
Author

How to disable portlet caching in JSR168 portlets?

John Zwick
Ranch Hand

Joined: Mar 02, 2009
Posts: 34
I have 2 pages in my portal that points to the same portlet (but with different portlet preferences). I have an issue where the page gets cached and when you click between the 2 pages, it doesnt reload properly with the updated portlet preferences. Is there a way I can disable caching? This is in Websphere Portal 6.1.

Thanks!
Bhagat Singh Rawat
Ranch Hand

Joined: Apr 04, 2009
Posts: 93
John Zwick wrote:I have 2 pages in my portal that points to the same portlet (but with different portlet preferences). I have an issue where the page gets cached and when you click between the 2 pages, it doesnt reload properly with the updated portlet preferences. Is there a way I can disable caching? This is in Websphere Portal 6.1.

Thanks!


Use the following line in doView method:

and also can use<expiration-cache>0</expiration-cache> in yours portlet deployment descriptor.


Brainbench Java 2.0 Fundamentals, J2EE 1.4
http://www.brainbench.com/transcript.jsp?pid=8192792
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: How to disable portlet caching in JSR168 portlets?