aspose file tools*
The moose likes Tomcat and the fly likes tomcat is not starting Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Tomcat
Bookmark "tomcat is not starting" Watch "tomcat is not starting" New topic
Author

tomcat is not starting

Sanjeev Charla
Ranch Hand

Joined: Apr 02, 2009
Posts: 90

i have installed jdk 6 and tomcat 6.
after windows is started, tomcat's is available in system tray.
but the service is not started.i tried to start that service manually.but it is not started... how to solve this problem... please help... thank you.
Deepak Bala
Bartender

Joined: Feb 24, 2006
Posts: 6661
    
    5

Please check the log file. What stack trace do you see ?


SCJP 6 articles - SCJP 5/6 mock exams - More SCJP Mocks
William Brogden
Author and all-around good cowpoke
Rancher

Joined: Mar 22, 2000
Posts: 12781
    
    5
If you are just getting started with servlets, it is a mistake to install Tomcat as a service because that make debugging difficult.

If this was my problem I would remove the service and install as a normal application. Start Tomcat from a command prompt window using startup.bat, NOT by clicking on startup.bat.

Bill
Sanjeev Charla
Ranch Hand

Joined: Apr 02, 2009
Posts: 90

few lines from log file:

[2009-06-27 10:33:49] [info] Procrun (2.0.4.0) started
[2009-06-27 10:19:14] [info] Running Service...
[2009-06-27 10:19:15] [info] Starting service...
[2009-06-27 10:19:15] [174 javajni.c] [error] The specified module could not be found.
[2009-06-27 10:19:15] [994 prunsrv.c] [error] Failed creating java C:\Program Files\Java\jre1.6.0\bin\client\jvm.dll
[2009-06-27 10:19:15] [1269 prunsrv.c] [error] ServiceStart returned 1
[2009-06-27 10:19:16] [info] Run service finished.
Daniel Walter
Greenhorn

Joined: Jun 28, 2009
Posts: 7
Hi,

Make sure you have permission to write throughout the Tomcat directory. I had the same problem once.

Dan
William Brogden
Author and all-around good cowpoke
Rancher

Joined: Mar 22, 2000
Posts: 12781
    
    5
If you are going to insist on running Tomcat as a service, you might want to read the procrun documentation.

Bill
Milton Petrosky
Greenhorn

Joined: Jun 25, 2009
Posts: 3
If you use Vista, try turning UAC(User Account Control) off. I found out UAC was restricting access to some subdirectories without me knowing.
Charbel Keyrouz
Ranch Hand

Joined: Jun 10, 2005
Posts: 46
Go to your jdk folder then /bin:
like this for example:

C:\Java\jdk1.6.0_13\bin
there is a dll file named msvcr71.dll

copy it and paste it under tomcatfolder/bin

and then your server should start normally.

Basically this problem occurs during the installation of Tomcat on vista because there is that stupid security that does not allow tomcat installer to access that file.
So the solution is to do it manually after you finish the installation.
Ravi Gupta
Ranch Hand

Joined: Jul 15, 2006
Posts: 38
I agree that installing Tomcat as a service may cause trouble, but blaming Vista for a "stupid" security feature that has helped massively cut down malware infections, is immature at best.

IF you want to know the no nonsense guide to setup tomcat on your Vista/XP/7 system, then you can take a look at http://gupta-ravi.spaces.live.com for this post.


help your PC help you best
http://simplepccare.spaces.live.com
Rohit Aggarawal
Ranch Hand

Joined: Jun 26, 2009
Posts: 39
sanjeev charla,

Is Your problem solved or yet to be solved?

-Rohit


SCJP 6.0
SCBCD for JEE 5

Charbel Keyrouz
Ranch Hand

Joined: Jun 10, 2005
Posts: 46
It is not the vista security that is stupid, it is the implementation.
If you are on a Linux operating system which is ,I suppose, way more secure than any of Microsoft's , you cannot face such issues.

Being able to do a process and only one part of it it is not allowed which will lead to malfunctioning of the whole scenario.

Anyway I apologize.
gkumar kumar
Greenhorn

Joined: May 01, 2007
Posts: 8

just check the java_home path..........u need to set java_home path it may solve the problem.
chek it out
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: tomcat is not starting