• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

ExecuteRequest javax.ejb.EJBException: EJB Exception:java.sql.SQLException:Write failed:Broken pipe

 
chaitanya kiranpvn
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

Iam facing the problem like this in the weblogic 10.3 server in 64 bit environment . my application is running with jrokit jvm and databse is mssqlserver 2000. my application is working fine in weblogic 8.1Sp5 and iam not facing this type of problems .now in 10.3 the broken pipe exception is occured but iam unable to findout the solution for this broken pipe. once this exception is occured i wanted to restart the server then it works fien after few hours again it occurs .hear is the details of my server

os:64 bit Centos
server: weblogic10.3
database: mssqlserver2000

connectionpool is 100.

heare is the stack trace iam geting in the server


please give your suggestions to solve this problem in my server.
thanks in advance

chaitanya kiran




 
Deepak Bala
Bartender
Posts: 6663
5
Firefox Browser Linux MyEclipse IDE
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Is your DB driver XA enabled ? What is the transaction setting for this connection ? Is the connection hitting more than one database ? Is the connection with the database being severed for any reason ?

When you test your connection with the sample sql (on the weblogic server admin console) do you see XA related errors every time the connection is being tested ? What happens if you remove the 'test connection' setting from this data source ? Perhaps your connections are leaking because of that.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic