aspose file tools*
The moose likes Ant, Maven and Other Build Tools and the fly likes installing maven 2 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » Ant, Maven and Other Build Tools
Bookmark "installing maven 2" Watch "installing maven 2" New topic
Author

installing maven 2

sam liya
Ranch Hand

Joined: Nov 25, 2008
Posts: 1223
when i am going to install maven 2 plugin it gives this error." Maven Integration for AJDT (Optional) (0.9.8.200905041414) requires feature "org.eclipse.ajdt (1.5.0)", or later version."

here is the site which i am going to install maven 2.
"http://m2eclipse.sonatype.org/update/"
can anyone tell me what is the error?
David Newton
Author
Rancher

Joined: Sep 29, 2008
Posts: 12617

That usually means that the version of the plugin you're installing requires a later version of another component--you should either upgrade your Eclipse, or downgrade the plugin. This should probably be in the IDE forum since it's an issue with the IDE/plugin, not specifically Maven.
sam liya
Ranch Hand

Joined: Nov 25, 2008
Posts: 1223
now it gives this error.
Maven issue tracking configurator for Mylyn 3.x (Optional) (0.9.6.20080905-0917) requires plug-in "org.eclipse.mylyn.tasks.ui (3.0.0)", or compatible.
can anyone tell me which pluging shuld i install?
David Newton
Author
Rancher

Joined: Sep 29, 2008
Posts: 12617

The one it told you to.

Don't just randomly check boxes in a dialog: if you're not going to use issue tracking integration don't install it, and if you are, install its dependencies.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: installing maven 2