This week's book giveaways are in the Java EE and JavaScript forums.
We're giving away four copies each of The Java EE 7 Tutorial Volume 1 or Volume 2(winners choice) and jQuery UI in Action and have the authors on-line!
See this thread and this one for details.
The moose likes Spring and the fly likes Help needed: getting a strange exception in WebFlow2:SnapshotNotFoundException Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of The Java EE 7 Tutorial Volume 1 or Volume 2 this week in the Java EE forum
or jQuery UI in Action in the JavaScript forum!
JavaRanch » Java Forums » Frameworks » Spring
Bookmark "Help needed: getting a strange exception in WebFlow2:SnapshotNotFoundException " Watch "Help needed: getting a strange exception in WebFlow2:SnapshotNotFoundException " New topic
Author

Help needed: getting a strange exception in WebFlow2:SnapshotNotFoundException

Shyam kumar
Ranch Hand

Joined: May 21, 2006
Posts: 146
Hi All,

Im running a web application built with SWF 2.0.6 and Spring 2.5.6/MVC on Resin 3.0.x webserver.

I'm getting the SnapshotNotFoundException exception when I come from subflow to the parent flow. This exception is comming randomly once in every 4 to 5 times of repeating the same flow.
The other weird thing is that I notice this happening on some of our servers and not on others even though the environments are same. I'm not able to debug this thing as this is not happening consistantly

Has someone experienced such issues with the snapshotgroup with the snapshot being lost from the conversation even though we are in the same flow and conversation on successive actions?

See the Strack trace
Caused by: org.springframework.webflow.execution.repository.s napshot.SnapshotNotFoundException: No flow execution snapshot could be found with id '1'; perhaps the snapshot has been removed?

org.springframework.webflow.execution.repository.F lowExecutionRestorationFailureException: A problem occurred restoring the flow execution with key 'e8s1'
at org.springframework.webflow.execution.repository.i mpl.DefaultFlowExecutionRepository.getFlowExecutio n(DefaultFlowExecutionRepository.java:102)
at org.springframework.webflow.executor.FlowExecutorI mpl.resumeExecution(FlowExecutorImpl.java:162)
at org.springframework.webflow.mvc.servlet.FlowHandle rAdapter.handle(FlowHandlerAdapter.java:183)
at org.springframework.web.servlet.DispatcherServlet. doDispatch(DispatcherServlet.java:875)
at org.springframework.web.servlet.DispatcherServlet. doService(DispatcherServlet.java:807)
...


Any kind of input will be appriciated. Thanks in advance...
Shyam kumar
Ranch Hand

Joined: May 21, 2006
Posts: 146
Hi all,

Raising an old problem yet again... An old ghost from the past haunting me once again .... Again getting the same exception in clustered environment!!!

Inside the webflow, sometimes we are getting the following exceptions. Don't really know what is happening here...

Caused by: org.springframework.webflow.execution.repository.snapshot.SnapshotNotFoundException: No flow execution snapshot could be found with id '2'; perhaps the snapshot has been removed?
at org.springframework.webflow.execution.repository.impl.SimpleFlowExecutionSnapshotGroup.getSnapshot(SimpleFlowExecutionSnapshotGroup.java:68)
at org.springframework.webflow.execution.repository.impl.DefaultFlowExecutionRepository.getFlowExecution(DefaultFlowExecutionRepository.java:100)
... 31 more

We are running automated webflow test in a clustered WAS environment, we are really stuck here.

Any kind of help.... any kind of input would be highly appriciated!!!
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Help needed: getting a strange exception in WebFlow2:SnapshotNotFoundException