aspose file tools*
The moose likes IDEs, Version Control and other tools and the fly likes module has not been deployed Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "module has not been deployed" Watch "module has not been deployed" New topic
Author

module has not been deployed

shashi sarle
Greenhorn

Joined: Oct 15, 2008
Posts: 12
Help please. I am new to Netbeans. I am trying to deploy the web service endpoint in the firstcup tutorial and get this error message from the Netbeans 6.5 IDE.

The output looks like this:

init:
deps-module-jar:
deps-ear-jar:
deps-jar:
library-inclusion-in-archive:
library-inclusion-in-manifest:
compile:
compile-jsps:
<drive>\Sun\AppServer\MySamples\firstcup-dukes-age\nbproject\build-impl.xml:557: Problem: failed to create task or type nbdeploy
Cause: The name is undefined.
Action: Check the spelling.
Action: Check that any custom tasks/types have been declared.
Action: Check that any <presetdef>/<macrodef> declarations have taken place.
BUILD FAILED (total time: 2 seconds)

The build-impl.xml target tag looks like this:

<target if="netbeans.home" name="-run-deploy-nb">
<nbdeploy clientUrlPart="${client.urlPart}" debugmode="false" forceRedeploy="${forceRedeploy}"/>
</target>

I have attached the xml files.

thanks in advance for any advice you can give me.
olze oli
Ranch Hand

Joined: Jun 20, 2009
Posts: 148
did you get this fixed?
if yes please tell me how you resolved this, i have the same problem
Ankit Garg
Sheriff

Joined: Aug 03, 2008
Posts: 9313
    
  17

There are very few chances of this getting solved in the Struts Forum. I'll move it to the IDE forum as the problems seems to be with netbeans (and not web services)...


SCJP 6 | SCWCD 5 | Javaranch SCJP FAQ | SCWCD Links
olze oli
Ranch Hand

Joined: Jun 20, 2009
Posts: 148
i'm not sure what went wrong but i did the following what solved it:
installed all librarys in the netbeans plugin system in the category Java web and EE
its working now
Dirk Simon
Greenhorn

Joined: Jan 04, 2010
Posts: 1
Hi, I think I've solved the probem, maybe just for me and just on NetBeans:
- take a look on the glassfish-console, in my case it misses the hibernate-libraries for deployment
- to attach it you just have to right click on your project -> Properties -> Frameworks -> Add (and add the hibernate-framework in my case)

-> if there are some other libs missed you've to read some Glassfish-doc's and deploy the libs by hand

Kamal Trivedi
Ranch Hand

Joined: May 22, 2006
Posts: 38
I also faced similar problem in Netbeans 6.8 Environment with Tomcat 6.0 & get resolved by adding libraries to project.

Using Netbeans 6.8->Select Project->Right Click Properties->Select Libraries->Inside Compile Tab->Select Add Library Button->Added
Java EE6 API Library &
Java EE6 GlassFish-v3 &
Java EE Web 6 API Library


& Compile & Run the project again.

These works for me.


Kamal.B.Trivedi
Michael Cropper
Ranch Hand

Joined: Sep 30, 2009
Posts: 137
Just come across this issue after posting my question here, http://www.coderanch.com/t/531653/JSP/java/best-way-display-results-set#2414095, but since it is the same issue may as well piggy back on this thread.

I have tried the above solutions but they haven't worked.

Has anyone got any other ideas to try?

Also, it is bizarre since my other package within netbeans builds and runs fine, so there must be something that has been removed somehow, somewhere.

Any help appreciated

Thanks
Michael Cropper
Ranch Hand

Joined: Sep 30, 2009
Posts: 137
Fixed

Issue was that I created an entry in the web.xml file BEFORE I actually created the java servlet and Netbeans being so smart couldn't handle this.

So I have just removed this entry and all is working perfectly again now :-)

Thanks
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: module has not been deployed