aspose file tools*
The moose likes HTML, CSS and JavaScript and the fly likes Problem using Spanish characters in Ajax response. Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » HTML, CSS and JavaScript
Bookmark "Problem using Spanish characters in Ajax response." Watch "Problem using Spanish characters in Ajax response." New topic
Author

Problem using Spanish characters in Ajax response.

pawan chopra
Ranch Hand

Joined: Jan 23, 2008
Posts: 408

Hi All,

I am passing spanish characters in ajax's response in my application. With tomcat 5.5 it is working fine but in tomcat 6 I am not able to see some characters properly. I am also getting following warning in the console window:

16-jul-2009 16:47:36 org.apache.tomcat.util.http.Parameters processParameters
ADVERTENCIA: Parameters: Invalid chunk ignored.


Please let me know where is the issue and how to resolve it.


Pawan Chopra
SCJP - DuMmIeS mInD
Eric Pascarello
author
Rancher

Joined: Nov 08, 2001
Posts: 15376
    
    6
Are you setting the proper content encoding?

Eric
pawan chopra
Ranch Hand

Joined: Jan 23, 2008
Posts: 408

below is the code I am using in my js file:


pawan chopra
Ranch Hand

Joined: Jan 23, 2008
Posts: 408

I have also tried with charset="UTF-8". But it is not working with tomcat 6.0.16. Its working fine with tomcat 5.5 and jboss.
pawan chopra
Ranch Hand

Joined: Jan 23, 2008
Posts: 408

I have resolved this I had to set charset while sending the response from servlet. Thanks!
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Problem using Spanish characters in Ajax response.
 
Similar Threads
Question Mock
Where is websphere http session cookie stored
Ajax response and accented characters (richfaces)
Special character string display
Post request doesnot support spanish characters in case of Weblogic + Solaris combination