This week's book giveaway is in the Clojure forum.
We're giving away four copies of Clojure in Action and have Amit Rathore and Francis Avila on-line!
See this thread for details.
Win a copy of Clojure in Action this week in the Clojure forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Problem using Spanish characters in Ajax response.

 
pawan chopra
Ranch Hand
Posts: 415
jQuery Mac Objective C
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,

I am passing spanish characters in ajax's response in my application. With tomcat 5.5 it is working fine but in tomcat 6 I am not able to see some characters properly. I am also getting following warning in the console window:

16-jul-2009 16:47:36 org.apache.tomcat.util.http.Parameters processParameters
ADVERTENCIA: Parameters: Invalid chunk ignored.


Please let me know where is the issue and how to resolve it.

 
Eric Pascarello
author
Rancher
Posts: 15385
6
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Are you setting the proper content encoding?

Eric
 
pawan chopra
Ranch Hand
Posts: 415
jQuery Mac Objective C
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
below is the code I am using in my js file:


 
pawan chopra
Ranch Hand
Posts: 415
jQuery Mac Objective C
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have also tried with charset="UTF-8". But it is not working with tomcat 6.0.16. Its working fine with tomcat 5.5 and jboss.
 
pawan chopra
Ranch Hand
Posts: 415
jQuery Mac Objective C
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have resolved this I had to set charset while sending the response from servlet. Thanks!
 
Consider Paul's rocket mass heater.
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic