aspose file tools*
The moose likes Tomcat and the fly likes Is it not possible to install apache-tomcat-6.0.20 as a service in WindowsXP SP3? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Is it not possible to install apache-tomcat-6.0.20 as a service in WindowsXP SP3?" Watch "Is it not possible to install apache-tomcat-6.0.20 as a service in WindowsXP SP3?" New topic
Author

Is it not possible to install apache-tomcat-6.0.20 as a service in WindowsXP SP3?

Varuna Seneviratna
Ranch Hand

Joined: Jan 15, 2007
Posts: 167
When I run the set up apache-tomcat-6.0.20.exe for WindowsXP I get the message from the Tomcat Setup as "Failed to install tomcat6 service check your settings and permissions".I have the permissions.The only thing I think that is different from the setup needs is the JRE version.But the tomcat-preconfigured-6.0.18.zip downloaded from coreservlets.com works fine with the J2SE 6 JRE.The setup always stops when the setup dialog box displays the message "using jvm:c:\program files\java\jre\bin\client\jvm.dll".There is no any other service or another version of Tomcat installed even as a service.


I installed Tomcat using apache-tomcat-6.0.20.exe But not as a service.Then from the bin I tried to run "tomcat6.exe service runner" But it did not start the service log is as follows

[2009-07-21 20:02:34] [info] Procrun (2.0.4.0) started
[2009-07-21 20:02:34] [info] Service Tomcat6 name Apache Tomcat 6
[2009-07-21 20:02:35] [info] Service Tomcat6 installed
[2009-07-21 20:02:35] [info] Procrun finished.
[2009-07-21 21:46:10] [info] Procrun (2.0.4.0) started
[2009-07-21 21:46:10] [info] Debugging Service...
[2009-07-21 21:46:10] [info] Starting service...
[2009-07-21 21:46:10] [1030 prunsrv.c] [error] Failed setting process executable
[2009-07-21 21:46:10] [1269 prunsrv.c] [error] ServiceStart returned 2
[2009-07-21 21:46:10] [info] Debug service finished.
[2009-07-21 21:46:10] [info] Procrun finished.
[2009-07-21 21:46:14] [info] Procrun (2.0.4.0) started
[2009-07-21 21:46:14] [info] Debugging Service...
[2009-07-21 21:46:14] [info] Starting service...
[2009-07-21 21:46:14] [1030 prunsrv.c] [error] Failed setting process executable
[2009-07-21 21:46:14] [1269 prunsrv.c] [error] ServiceStart returned 2
[2009-07-21 21:46:14] [info] Debug service finished.
[2009-07-21 21:46:14] [info] Procrun finished.
[2009-07-21 21:46:24] [info] Procrun (2.0.4.0) started
[2009-07-21 21:46:24] [info] Running Service...
[2009-07-21 21:46:24] [info] Starting service...
[2009-07-21 21:46:24] [1030 prunsrv.c] [error] Failed setting process executable
[2009-07-21 21:46:24] [1269 prunsrv.c] [error] ServiceStart returned 2
[2009-07-21 21:46:24] [info] Run service finished.
[2009-07-21 21:46:24] [info] Procrun finished.
[2009-07-21 21:46:28] [info] Procrun (2.0.4.0) started
[2009-07-21 21:46:28] [info] Running Service...
[2009-07-21 21:46:28] [info] Starting service...
[2009-07-21 21:46:28] [1030 prunsrv.c] [error] Failed setting process executable
[2009-07-21 21:46:28] [1269 prunsrv.c] [error] ServiceStart returned 2
[2009-07-21 21:46:28] [info] Run service finished.
[2009-07-21 21:46:28] [info] Procrun finished.
[2009-07-21 21:46:31] [info] Procrun (2.0.4.0) started
[2009-07-21 21:46:31] [info] Running Service...
[2009-07-21 21:46:31] [info] Starting service...
[2009-07-21 21:46:32] [1030 prunsrv.c] [error] Failed setting process executable
[2009-07-21 21:46:32] [1269 prunsrv.c] [error] ServiceStart returned 2
[2009-07-21 21:46:32] [info] Run service finished.
[2009-07-21 21:46:32] [info] Procrun finished.
[2009-07-21 21:46:35] [info] Procrun (2.0.4.0) started
[2009-07-21 21:46:35] [info] Running Service...
[2009-07-21 21:46:35] [info] Starting service...
[2009-07-21 21:46:35] [1030 prunsrv.c] [error] Failed setting process executable
[2009-07-21 21:46:35] [1269 prunsrv.c] [error] ServiceStart returned 2
[2009-07-21 21:46:35] [info] Run service finished.
[2009-07-21 21:46:35] [info] Procrun finished.
[2009-07-21 21:53:44] [info] Procrun (2.0.4.0) started
[2009-07-21 21:53:44] [info] Debugging Service...
[2009-07-21 21:53:44] [info] Starting service...
[2009-07-21 21:53:44] [1030 prunsrv.c] [error] Failed setting process executable
[2009-07-21 21:53:44] [1269 prunsrv.c] [error] ServiceStart returned 2
[2009-07-21 21:53:44] [info] Debug service finished.
[2009-07-21 21:53:44] [info] Procrun finished.
[2009-07-21 21:54:06] [info] Procrun (2.0.4.0) started
[2009-07-21 21:54:06] [info] Debugging Service...
[2009-07-21 21:54:06] [info] Starting service...
[2009-07-21 21:54:06] [1030 prunsrv.c] [error] Failed setting process executable
[2009-07-21 21:54:06] [1269 prunsrv.c] [error] ServiceStart returned 2
[2009-07-21 21:54:06] [info] Debug service finished.
[2009-07-21 21:54:06] [info] Procrun finished.
[2009-07-21 21:55:44] [info] Procrun (2.0.4.0) started
[2009-07-21 21:55:44] [info] Debugging Service...
[2009-07-21 21:55:44] [info] Starting service...
[2009-07-21 21:55:44] [1030 prunsrv.c] [error] Failed setting process executable
[2009-07-21 21:55:44] [1269 prunsrv.c] [error] ServiceStart returned 2
[2009-07-21 21:55:44] [info] Debug service finished.
[2009-07-21 21:55:44] [info] Procrun finished.
[2009-07-21 21:55:44] [info] Procrun (2.0.4.0) started
[2009-07-21 21:55:44] [info] Debugging Service...
[2009-07-21 21:55:44] [info] Starting service...
[2009-07-21 21:55:44] [1030 prunsrv.c] [error] Failed setting process executable
[2009-07-21 21:55:44] [1269 prunsrv.c] [error] ServiceStart returned 2
[2009-07-21 21:55:44] [info] Debug service finished.
[2009-07-21 21:55:44] [info] Procrun finished.
[2009-07-21 21:55:45] [info] Procrun (2.0.4.0) started
[2009-07-21 21:55:45] [info] Debugging Service...
[2009-07-21 21:55:45] [info] Starting service...
[2009-07-21 21:55:45] [1030 prunsrv.c] [error] Failed setting process executable
[2009-07-21 21:55:45] [1269 prunsrv.c] [error] ServiceStart returned 2
[2009-07-21 21:55:45] [info] Debug service finished.
[2009-07-21 21:55:45] [info] Procrun finished.


Your ideas please!!!


Varuna Seneviratna
Vijitha Kumara
Bartender

Joined: Mar 24, 2008
Posts: 3855

CrossPosted


SCJP 5 | SCWCD 5
[How to ask questions] [Twitter]
Misha Ver
Ranch Hand

Joined: Mar 03, 2008
Posts: 470
Varuna Seneviratna wrote:The setup always stops when the setup dialog box displays the message "using jvm:c:\program files\java\jre\bin\client\jvm.dll"


Any other messages during set up? Are you sure that you are using administrative account? Do you have any anti-virus software running on you machine?
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Is it not possible to install apache-tomcat-6.0.20 as a service in WindowsXP SP3?