my dog learned polymorphism*
The moose likes JBoss/WildFly and the fly likes jboss started.. but localhost:8080 throwing an error Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Reply locked New topic
Author

jboss started.. but localhost:8080 throwing an error

Srikanthh Ar
Greenhorn

Joined: Jul 14, 2009
Posts: 18
i used eclipse and coded a servlet.

i used jboss to debug. while debugging i got this exception

09:42:30,734 ERROR [Http11Protocol] Error starting endpoint
java.net.BindException: Address already in use: JVM_Bind:8080

and at last i got

09:42:30,734 INFO [Server] JBoss (MX MicroKernel) [4.2.3.GA (build: SVNTag=JBoss_4_2_3_GA date=200807181439)] Started in 30s:125ms

in my console...

then i deployed my war file..

09:43:00,718 INFO [TomcatDeployer] deploy, ctxPath=/one, warUrl=.../tmp/deploy/tmp7742847336317735345one-exp.war/
09:43:00,812 INFO [JBossCacheManager] Starting JBossManager

came in my eclipse console....

when i opened the browser and typed http://localhost:8080

i got a page not found error....

whether my jboss started or not.. my eclipse console showing jboss started... but http://localhost:8080 is not working.. throwing an error.. why is it so...

what's the problem...
Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 9930
    
159

java.net.BindException: Address already in use: JVM_Bind:8080


That means an error. See this for details http://www.jboss.org/community/wiki/DebugBindException


[My Blog] [JavaRanch Journal]
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5812
    
    7

Srikanthh, please do not ask the same question in multiple forums (your other post which started in the servlets forum and went to the IDE forum also ended up here.). Now I have to decide which one to lock. I'll lock this one. Discussion continued at http://www.coderanch.com/t/455329/JBoss/http-localhost-not-opening


JBoss In Action
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: jboss started.. but localhost:8080 throwing an error
 
Similar Threads
Unable to find a cluster rule set error
JBOSS 4.23 and Java 6 on Mac OS X leopard
not getting jmx console
http://localhost:8080 is not opening
Running JBOSS 4.2.3 and java 6 on mac os x leopard