File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes Other Application Frameworks and the fly likes Stripes error Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login

Win a copy of Java Interview Guide this week in the Jobs Discussion forum!
JavaRanch » Java Forums » Frameworks » Other Application Frameworks
Bookmark "Stripes error" Watch "Stripes error" New topic

Stripes error

Wesley Baker
Ranch Hand

Joined: Aug 20, 2008
Posts: 45
This one has really got me frustrated

I am receiving a MissingResourceException error that states:

The file is in the WEB-INF/classes folder, and it has all permissions enabled. It also contains the validation.required.valueNotPresent key, so I am at a complete loss as to why Stripes is not seeing the file. I have also tried to remove the file, and the error message DOES change to say it can't find the file, so I know Stripes is seeing it.

To even further frustrate the situation, the validation works perfectly on my local machine when I run the project through Netbeans, but when I deploy it to the production server, I get this error.

I did some Googling and only found one person with this error, and there was no resolution that I could find. HELP!!!
Wesley Baker
Ranch Hand

Joined: Aug 20, 2008
Posts: 45

Must have been some weird classpath issue (most likely PEBKAC), because I placed the file in another directory and manually added that directory to the Glassfish classpath and it works now. Go figure.
I agree. Here's the link:
subject: Stripes error
jQuery in Action, 3rd edition