Win a copy of Clojure in Action this week in the Clojure forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Unable to initialize TldLocationsCache

 
Pawan Arora
Ranch Hand
Posts: 105
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I repeatedly getting the above exception whenever I try to run the body of custom tags by using classic tag handler.

The code of JSP file is:



The code of TLD file is:



the code of Classic tag handler is:


and the exception, which I'm getting is:


I'm calling a JSP page directly from the request, instead of request it from the servlet. I've not configured web.xml file. What's wrong I'm doing?

 
Chinmaya Chowdary
Ranch Hand
Posts: 432
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Pawan. Can you please tell, how many .tld files are present in your application? I think there is an error present in one of your .tld (not this .tld).
 
Pawan Arora
Ranch Hand
Posts: 105
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Only this one.
 
Chinmaya Chowdary
Ranch Hand
Posts: 432
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Restart the server and send request.
 
Pawan Arora
Ranch Hand
Posts: 105
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I just changed the value of <body-content> element in TLD to JSP, and now it's working fine.
 
Chinmaya Chowdary
Ranch Hand
Posts: 432
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Pawan. For BodyTagSupport, 'scriptless' is one of the valid option of <body-content>. Can you please tell, why it is running after changing <body-content> option to 'JSP'?
 
Pawan Arora
Ranch Hand
Posts: 105
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It's working fine by calling Tag's body with the value 'scriptless' too. There was actually a problem in deployment. I should have been more specific in specify my problem reason. Anyway, Thanks for your time.
 
I agree. Here's the link: http://aspose.com/file-tools
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic