This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes JBoss/WildFly and the fly likes Enabling SSL on JBoss Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "Enabling SSL on JBoss" Watch "Enabling SSL on JBoss" New topic
Author

Enabling SSL on JBoss

James Dekker
Ranch Hand

Joined: Dec 09, 2006
Posts: 215
How can I enable SSL on JBoss 5 on a Linux (Red Hat - Fedora 8) box?

What I've done so far is:

(1) Create a test keystore by doing this and then answering all the questions.

(2) Placed the newly generated server.keystore in $JBOSS_HOME/server/default/conf

(3) Make the following change in the server.xml in $JBOSS_HOME/server/default/deploy/jbossweb.sar to include this:



What more do I need to do to enable full SSL client authentication?

A lot of the web sites on Google state how to enable SSL for JBoss 3 - 4. I need a good tutorial for JBoss 5.

Happy programming,

James
Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 9960
    
163

See this http://www.coderanch.com/t/452227/JBoss/enable-https-jboss

Also, this looks incorrect in your configuration:



jboss.server.home.dir points to $JBOSS_HOME/server/default (assuming you are starting the default configuration) folder. So that property should be set to:



A lot of the web sites on Google state how to enable SSL for JBoss 3 - 4. I need a good tutorial for JBoss 5.


JBoss AS 5 documentation is scattered across various wiki and forum posts. You can search these places or you can buy the JBoss In Action book by Peter Johnson which concentrates on various configurations in JBoss AS 5.


[My Blog] [JavaRanch Journal]
James Dekker
Ranch Hand

Joined: Dec 09, 2006
Posts: 215
Thank you for all of your help...

Actually, I already did change that to (in $JBOSS_HOME/server/default/deploy/jbossweb.sar/server.xml):



The problem now is that when JBoss starts it logs this exception (during start-up) (but I am still able to view everything under http://localhost:8080/):



I do know that's there's more to be done to enable full SSL client authentication....


 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Enabling SSL on JBoss
 
Similar Threads
http to https redirect jboss 5.0.1 GA
Keystore was tampered with, or password was incorrect
enable https on jboss 5
Can't Get SSL/HTTPS To Work
Configure https