This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes Groovy and the fly likes 64bit Groovy Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Languages » Groovy
Bookmark "64bit Groovy" Watch "64bit Groovy" New topic
Author

64bit Groovy

Chris Bohannon
Greenhorn

Joined: Jul 28, 2009
Posts: 8

Hello,

I am running Windows Vista Home Premium. I have downloaded and installed Groovy version 1.6.3. At the command line I enter groovysh and recieve the following error:

error: dynamic library C:\Program Files\Java\jdk1.6.0_13\jre\bin\server\jvm.dll exists but could not be loaded!
error (win code 193): (null)
error: could not find a client or server jvm under C:\Program Files\Java\jdk1.6.0_13
please check that it is a valid jdk / jre containing the desired type of jvm

Groovy seemed to install fine, however, I can't seem to get this to run. The jvm.dll does exist in the correct directory. I have also installed a 32 bit jdk as well. I have tried to change the path using groovy --javahome and the 32 bit directory but that returns the same error. Is there a way I can get this to work on a 64 bit system?

Thanks!
Gregg Bolinger
GenRocket Founder
Ranch Hand

Joined: Jul 11, 2001
Posts: 15299
    
    6

This isn't going to be very helpful but I've been running Groovy (Java) fine on Vista 64, Windows 7 64, Ubuntu 64, and OSX. If I were you I would remove all versions of Java from your machine. Download/install the 64bit version of the latest JDK, and make sure your JAVA_HOME var points to that particular path and try again. Remember that if you modify your env variables you need a new command prompt to be opened. Existing command prompts won't pick up the changes.


GenRocket - Experts at Building Test Data
Chris DeLashmutt
Greenhorn

Joined: Jan 20, 2005
Posts: 5
The problem is that groovy has some helper EXEs that are still linked to the 32 bit version of the JVM. If you use "groovysh.bat" or "groovy.bat", you should be able to launch things successfully. There appears to be an JIRA ticket open related to this issue at http://jira.codehaus.org/browse/GROOVY-3382.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: 64bit Groovy
 
Similar Threads
eclipse doesn't run on vista (x64)
Eclipse start but return exit code=1
i am getting error when i try to run eclips
how to find Java Server VM
moving from Java 5 to Java 6