File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Struts and the fly likes Upgrade struts from 2.0.11 to 2.1.6 and having issues with xworkBasicConverter Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Soft Skills this week in the Jobs Discussion forum!
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "Upgrade struts from 2.0.11 to 2.1.6 and having issues with xworkBasicConverter" Watch "Upgrade struts from 2.0.11 to 2.1.6 and having issues with xworkBasicConverter" New topic
Author

Upgrade struts from 2.0.11 to 2.1.6 and having issues with xworkBasicConverter

Anand Krishnanandam
Greenhorn

Joined: May 23, 2006
Posts: 25
Hi,
I am upgrading struts from 2.0.11 to 2.1.6 And I used the follwong link/guide to do the changes to make it work.
http://cwiki.apache.org/S2WIKI/troubleshooting-guide-migrating-from-struts-20x-to-21x.html

With the changes made (almost everything that is relevant for our app) I was able to deploy. But when I access the page I get a StackOverFlowError at
at com.Fooinc.common.web.converter.NumberConverter.convertValue(NumberConverter.java:40)
at com.Fooinc.common.web.converter.NumberConverter.convertValue(NumberConverter.java:23)
at com.opensymphony.xwork2.conversion.impl.DefaultTypeConverter.convertValue(DefaultTypeConverter.java:72)
at com.opensymphony.xwork2.conversion.impl.XWorkBasicConverter.convertValue(XWorkBasicConverter.java:134)
at com.Fooinc.common.web.converter.NumberConverter.convertValue(NumberConverter.java:40)
at com.Fooinc.common.web.converter.NumberConverter.convertValue(NumberConverter.java:23)
at com.opensymphony.xwork2.conversion.impl.DefaultTypeConverter.convertValue(DefaultTypeConverter.java:72)
at com.opensymphony.xwork2.conversion.impl.XWorkBasicConverter.convertValue(XWorkBasicConverter.java:134)




this is happenning at this line of my jsp page .




especially

if I take that out the page loads fine.
This was working fine on 2.0.11. Am I missing something.

ANy help would be greatly appreciated.

Thanks,
Anand.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Upgrade struts from 2.0.11 to 2.1.6 and having issues with xworkBasicConverter