aspose file tools*
The moose likes JDBC and the fly likes Attachment functionality is not working when project is running on oracle10g Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Databases » JDBC
Bookmark "Attachment functionality is not working when project is running on oracle10g" Watch "Attachment functionality is not working when project is running on oracle10g" New topic
Author

Attachment functionality is not working when project is running on oracle10g

anuradha Java
Greenhorn

Joined: Mar 28, 2008
Posts: 5
My Project is working well with oracel9i but when i connected it with oracle 10g and trying to attach files then it is giving the error:

anuradha Java
Greenhorn

Joined: Mar 28, 2008
Posts: 5
I have place the jar files ojdbc14 and ojdbc14_g at Program Files\Java\jdk1.5.0_12\jre\lib\ext
anuradha Java
Greenhorn

Joined: Mar 28, 2008
Posts: 5
In this project we are using struts, hibernate. Is there any thing to change in hibernate for attachment
Jesper de Jong
Java Cowboy
Saloon Keeper

Joined: Aug 16, 2005
Posts: 14272
    
  21

First, check your private messages for an administrative matter from JavaRanch.

Did you try Googling for "ORA-22993"?

http://ora-22993.ora-code.com/
http://www-css.fnal.gov/dsg/external/oracle_dcm/9iv2/appdev.920/a96591/adl06faq.htm

It looks like this has something to do with inserting a BLOB or CLOB the wrong way, where you specify the size of the object you are inserted wrongly. Without seeing your source code, it's hard to tell what exactly is wrong with your program.

Java Beginners FAQ - JavaRanch SCJP FAQ - The Java Tutorial - Java SE 8 API documentation
anuradha Java
Greenhorn

Joined: Mar 28, 2008
Posts: 5
But it is working fine with oracle 9i.
This problem is with oracle10g only.

Do you have any idea that what should be changes specifically oracle10g?
Jeanne Boyarsky
author & internet detective
Marshal

Joined: May 26, 2003
Posts: 30764
    
156

Did you try Googling for "ORA-22993"?

This is good advice. I notice you didn't reply to it.

Just because something worked in a previous version doesn't mean you are home free. It could have been a bug in the previous release. It could be a system change. It could be almost anything. You have to pursue it as a new problem until you know more.


[Blog] [JavaRanch FAQ] [How To Ask Questions The Smart Way] [Book Promos]
Blogging on Certs: SCEA Part 1, Part 2 & 3, Core Spring 3, OCAJP, OCPJP beta, TOGAF part 1 and part 2
Gajen Pingalkar
Ranch Hand

Joined: Aug 29, 2006
Posts: 37
Sorry Jeanne,
We did googling for "ORA-22993" , but not get satisfied answer.
Here is our code for saving file by JDBC.


Thanks in advance.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Attachment functionality is not working when project is running on oracle10g