aspose file tools*
The moose likes IDEs, Version Control and other tools and the fly likes source not found in Eclipse during debugging Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "source not found in Eclipse during debugging" Watch "source not found in Eclipse during debugging" New topic
Author

source not found in Eclipse during debugging

Dariusz Kominek
Greenhorn

Joined: Aug 06, 2009
Posts: 2
Hello! I have an Eclipse problem. When I debug jee application i get an error: source not found. This happens when I get to the end of the java file and press step over. I think that after I got to the end of one java file I should be able to see everything displayed in built-in browser and then I could press the button and debug another servlet. It was like this before I formatted the hard drive (I did it because of a computer virus). So now I get the message: "source not found" and I can press the button: "Edit source lookup path". But I don't know what path shoud I use. Please someone help me!

I have windows xp installed eclipse europa and websphere application server community edition.
The same problem was with Tomcat and eclipse ganymede and eclipse galileo.
Lars Vogel
Ranch Hand

Joined: Oct 10, 2007
Posts: 55
You can add the source to a jar you are using. This is described here: http://www.vogella.de/articles/Eclipse/article.html#classpath

If you get the message for standard Java code, add the source code to rt.jar. You find a src.zip in your JDK installation.


Tutorials about Java, Eclipse and Webprogramming http://www.vogella.de
Dariusz Kominek
Greenhorn

Joined: Aug 06, 2009
Posts: 2
Lars thanks for your reply.
I tried to add two paths (to my *.java and *.class files) in Edit Lookup Source. But it doesn't help.
I also tried to add source to rt.jar and resource.jar and it doesn't help either.
I cannot find src.zip on my computer - it isn't in jdk folder.
When I add j2ee.jar and javaee.jar debugger wants me to add source for HttpServlet.class.
Do you have any other ideas Lars?
Any help will be appreciated.

I'm working on Ubuntu, Eclipse Galileo and WASCE.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: source not found in Eclipse during debugging