This week's book giveaway is in the OCMJEA forum.
We're giving away four copies of OCM Java EE 6 Enterprise Architect Exam Guide and have Paul Allen & Joseph Bambara on-line!
See this thread for details.
The moose likes Oracle/OAS and the fly likes internal server error Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCM Java EE 6 Enterprise Architect Exam Guide this week in the OCMJEA forum!
JavaRanch » Java Forums » Products » Oracle/OAS
Bookmark "internal server error" Watch "internal server error" New topic
Author

internal server error

John Smith
Ranch Hand

Joined: Aug 21, 2004
Posts: 48
Hi All:

I installed oracle report server 10.1.2.02
I tried the following url and it display the page properly that ask Test run Job:
http://xxx/reports/rwwebservice?operation=runJob

When I tried the url:
http://xxx/reports/rwservlet/showJobs?server=rep_xxx_oracleas3
It is suppose to redirect me to an url to login.
It did the first time. I was able to login using the idrcladmin.
It gave me the page Report Server Queue Status.
Please note, my oracle report server is installed on windows 2000 SP4 in a vmware guest operating system workstation 6.5.1. I have internet connection in my guest operating system and I am trying the url inside
the guesting operating system.
But after I restart the operating system when I tried the url http://xxx/reports/rwservlet/showJobs?server=rep_xxx_oracleas3, it try to redirect me to the login page:

New url:
http://xxx:7777/plus/orasso/orasso.wwsso_app_admin.ls_login?Site2pstoreToken=v1.4~E5DE4992~5CFF563A653986204B9B04019AE4D129CF0BB1A298D032A11FDF68ACD637E48672F62C4B6E8A048E4C55BFBB01AF2F93CB1065AE73753291E19C8CF7FCD1DDF1D52C1D525F9A107176E14356A4815260A8B856690E26B59ACCD09C6A1DB666807227D7870A4D15DFD9CBA473EAEF0F0001B8A44C8B683138B240C6A8CC44D730DB090B330C1057E39715ECC56E5395B6F89EDC185287720F00DECCF03E796F20470A1732CB419AF416475AFCA066946B655BA5CD8425CC4BD478FA2BCF44AC58

But I get the following error on the page.
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, you@your.address and inform them of the time the error occurred, and anything you might have done that may have caused the error.



Oracle-Application-Server-10g/10.1.2.0.2 Oracle-HTTP-Server Server at xxx Port 7777Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, you@your.address and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.



--------------------------------------------------------------------------------

Oracle-Application-Server-10g/10.1.2.0.2 Oracle-HTTP-Server Server at xxx Port 7777


More information about this error may be available in the server error log.

Here is the contents of my apache server log
C:\OraHome_3\Apache\Apache\logs\error_log.1249732800:
[Sat Aug 08 09:47:38 2009] [error] [client 192.168.2.136] [ecid: 1249739258:192.168.2.136:2768:3016:1,0] MOD_OC4J_0013: Failed to call destination: OC4J_BI_Forms's service() to service the request.
[Sat Aug 08 09:47:50 2009] [error] MOD_OC4J_0191: Missing information from OC4J notification. ias-cluster:C_192.168.2.136.910040.121a94bcb04.-8000, ias-instance:jadeite1000.xxx, hostname:xxx, opmnid:18677962, oc4j-instance:home, oc4j-island:default_island, ajp-host:-missing-, ajp-port:-missing-

C:\OraHome_3\j2ee\home\log\home_default_island_1\server.txt
09/08/08 10:10:47 Published an event: C_192.168.2.136.910040.121a94bcb04.-8000#jadeite1000.xxx#18677962#D#home#default_island&xxx&HTTP:xxx#12503&RMI:xxx#12403&JMS:xxx#12603

How can I tell what version of Oracle report server did I installed. Is there a command I can run to give me feedback what version of oracle report server.

Any hint or help will be greatly appreciated.

Yours,

Frustrated.
John Smith
Ranch Hand

Joined: Aug 21, 2004
Posts: 48
Hi:

First I like to thank you anyone viewing this problem or replying to my problem.
I have the following additional information:

I tried this url:
//xxx:7777/xxx/orasso/orasso.home
I get the following error:
Forbidden
You don't have permission to access /xxx/orasso/orasso.home on this server.


--------------------------------------------------------------------------------

Oracle-Application-Server-10g/10.1.2.0.2 Oracle-HTTP-Server Server at xxx Port 7777

I run my oracle database and oracle report server in a vmware guesting operating system running on windows 2000 serve sp4.
I have different versions of vmware depending on the date.
The latest version have the above server error.
Before the latest version I didnot have the above server error when I did the following:

I went to the following url:
//xxx/reports/rwservlet/showJobs?server=rep_xxx_oracleas3

and it redirects to a login page.
But when I tried to login using the idrcladmin it tells me the password for the id has expired. So I login into the userid ORASSO.
And ran the following command:
execute WWSSO_OID_INTEGRATION.reset_passwd('ORCLADMIN',null,'mychau1');

Than I was able to login using the id:ORCLADMIN.
Before I did this change of the orcladmin 's password.
When I run the opmnctl status, I get the following:
C:\OraHome_3\opmn\bin>opmnctl status

Processes in Instance: jadeite1000.xxx
-------------------+--------------------+---------+---------
ias-component | process-type | pid | status
-------------------+--------------------+---------+---------
DSA | DSA | N/A | Down
LogLoader | logloaderd | N/A | Down
dcm-daemon | dcm-daemon | N/A | Down
OC4J | home | 0 | NONE
OC4J | OC4J_BI_Forms | 0 | NONE
WebCache | WebCache | 1948 | Alive
WebCache | WebCacheAdmin | 1696 | Alive
HTTP_Server | HTTP_Server | 980 | Alive

After the change of the password for the idrcladmin and after rebooting the computer, I get the following:
C:\OraHome_3\opmn\bin>opmnctl status

Processes in Instance: jadeite1000.xxx
-------------------+--------------------+---------+---------
ias-component | process-type | pid | status
-------------------+--------------------+---------+---------
DSA | DSA | N/A | Down
LogLoader | logloaderd | N/A | Down
dcm-daemon | dcm-daemon | N/A | Down
OC4J | home | 4048 | Alive
OC4J | OC4J_BI_Forms | 784 | Alive
WebCache | WebCache | 2020 | Alive
WebCache | WebCacheAdmin | 2012 | Alive
HTTP_Server | HTTP_Server | 2048 | Alive



Basically HOME AND OC4J_BI_FORMS ARE NOW BOTH ALIVE AND BEFORE THEY WERE NOT ALIVE.
I also did comparison of the original and new ias.properties and the opmn.xml file and it shows no change.
This means that since HOME and OC4J_BI_FORMS ARE NOW BOTH ALIVE AND because of that I cannot get into the login page.
//xxx:7777/sso/jsp/login.jsp?


Here is the contents of my apache server log
C:\OraHome_3\Apache\Apache\logs\error_log.1249732800:
[Sat Aug 08 09:47:38 2009] [error] [client 192.168.2.136] [ecid: 1249739258:192.168.2.136:2768:3016:1,0] MOD_OC4J_0013: Failed to call destination: OC4J_BI_Forms's service() to service the request.
[Sat Aug 08 09:47:50 2009] [error] MOD_OC4J_0191: Missing information from OC4J notification. ias-cluster:C_192.168.2.136.910040.121a94bcb04.-8000, ias-instance:jadeite1000.xxx, hostname:xxx, opmnid:18677962, oc4j-instance:home, oc4j-island:default_island, ajp-host:-missing-, ajp-port:-missing-

Does this mean the port for

OC4J | home | 4048 | Alive
OC4J | OC4J_BI_Forms | 784 | Alive

conflict with some server. Example maybe with the apache server or the oc4j application server.
If so, where can I find the port number used by the apache or oc4j application server.


Here is a a small detail of the C:\OraHome_3\opmn\conf\opmn.xml
<ias-component id="OC4J">
<dependencies>
<OID infrastructure="true"/>
</dependencies>
<process-type id="home" module-id="OC4J" status="enabled">
<module-data>
<category id="start-parameters">
<data id="java-options" value="-Xrs -server -Djava.security.policy=$ORACLE_HOME/j2ee/home/config/java2.policy -Djava.awt.headless=true"/>
</category>
<category id="stop-parameters">
<data id="java-options" value="-Djava.security.policy=$ORACLE_HOME/j2ee/home/config/java2.policy -Djava.awt.headless=true"/>
</category>
</module-data>
<start timeout="600" retry="2"/>
<stop timeout="120"/>
<restart timeout="720" retry="2"/>
<port id="ajp" range="12501-12600"/>
<port id="rmi" range="12401-12500"/>
<port id="jms" range="12601-12700"/>
<process-set id="default_island" numprocs="1"/>
</process-type>
<process-type id="OC4J_BI_Forms" module-id="OC4J">
<environment>
<variable id="DISPLAY" value="localhost:0"/>
<variable id="LD_LIBRARY_PATH" value="C:\OraHome_3\lib32:C:\OraHome_3\lib:C:\OraHome_3\jdk\jre\lib\sparc"/>
</environment>
<module-data>
<category id="start-parameters">
<data id="java-options" value="-server -Xrs -Djava.security.policy=C:\OraHome_3\j2ee\OC4J_BI_Forms\config\java2.policy -Djava.awt.headless=true -Xmx512M -Xms128M "/>
<data id="oc4j-options" value="-properties -userThreads "/>
</category>
<category id="stop-parameters">
<data id="java-options" value="-Djava.security.policy=C:\OraHome_3\j2ee\OC4J_BI_Forms\config\java2.policy -Djava.awt.headless=true"/>
</category>
<category id="urlping-parameters">
<data id="/reports/rwservlet/pingserver?start=auto" value="200"/>
</category>
</module-data>
<start timeout="900" retry="2"/>
<stop timeout="120"/>
<restart timeout="720" retry="2"/>
<port id="ajp" range="12501-12600"/>
<port id="rmi" range="12401-12500"/>
<port id="jms" range="12601-12700"/>
<process-set id="default_island" numprocs="1"/>
</process-type>
</ias-component>

Here is small detail of my C:\OraHome_3\config\ias.properties:
Version=10.1.2.0.2
InstallType=Business
Components=Apache,J2EE,WebCache,JServ,Portal,Wireless,Discoverer,Personalization,Reports,Forms
IASname=jadeite1000.xxx
InstanceNamesList=jadeite1000.xxx
IASpassword=054f9a3f737c07b9aaf21c08faf054b3296933e30edcbaa752
IASSvcpassword=051e39b076c2b7e24f97428fb001c5c752b316f1d391863b18
UserName=Administrator
InfrastructureUse=true
DatabaseManagedClusterSupport=true
OIDhost=xxx
OIDport=389
OIDsslport=636

On another forum someone posted this reply to my question:
"I support Oracle Application Server. I'm not exactly sure where your problem is but you might want to check if there's a ajp port conflict. You can find your ajp port setting at $OH/opmn/config/opmn.xml. Search for ajp. Then check if your box is using that port or just try another port number and restart your app srv.

Sat Aug 08 09:47:50 2009] [error] MOD_OC4J_0191: Missing information from OC4J notification. ias-cluster:C_192.168.2.136.910040.121a94bcb04.-8000, ias-instance:jadeite1000.xxx, hostname:xxx, opmnid:18677962, oc4j-instance:home, oc4j-island:default_island, ajp-host:-missing-, ajp-port:-missing-

MOD_OC4J_0191
If OracleAS 10.1.3 has been integrated with OracleAS 10.1.2 the OPMN / ONS will invoke a ping request via the 10.1.2 HTTP Server to check on the availability of the 10.1.3 OC4J instances. The ping request will only succeed if the default-web-site protocol is set to ajp.

The error - MOD_OC4J_0191 - occurs because the OracleAS 10.1.3 default instance - typically labelled Home - has default-web-site protocol set to HTTP. The Home OC4J instance by default has this protocol set to be HTTP as it is this instance which typically hosts the OracleAS 10.1.3 ascontrol application. The error is harmless and can be ignored.


Also,
Try this:
Edit your $OH/opmn/conf/opmn.xml (Just change the protocol from http to ajp

from
<port id="default-web-site" range="7777" protocol="http"/>
To
<port id="default-web-site" range="12601-12700" protocol="ajp"/>

Run the update config for command for opmn.xml if you're not using the asconsole.

You can find your version number defined in the $OH/config/ias.properties set in the Version variable.

Always take a backup before making changes. You won't regret it.

Good luck."

In the reply " Then check if your box is using that port or just try another port number and restart your app srv."
How can I check what port number is my box using?

In the reply "If OracleAS 10.1.3 has been integrated with OracleAS 10.1.2 the OPMN / ONS will invoke a ping request via the 10.1.2 HTTP Server to check on the availability of the 10.1.3 OC4J instances. The ping request will only succeed if the default-web-site protocol is set to ajp."

How do I ping a request via the 10.1.2 HTTP server to check on the avilability of the 10.1.3 OC4J instances?

I checked my opmn.xml file I cannot find this tag:
<port id="default-web-site" range="7777" protocol="http"/>


Can you please tell me which url and where can I login in with Oracle support.

Thank you for your help!!! Greatly appreciated it!!! Any hint would be great.

Yours,

Frustrated.
 
jQuery in Action, 2nd edition
 
subject: internal server error