This week's book giveaway is in the OO, Patterns, UML and Refactoring forum.
We're giving away four copies of Refactoring for Software Design Smells: Managing Technical Debt and have Girish Suryanarayana, Ganesh Samarthyam & Tushar Sharma on-line!
See this thread for details.
The moose likes Other JSE/JEE APIs and the fly likes JavaMail sending problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Java » Other JSE/JEE APIs
Bookmark "JavaMail sending problem" Watch "JavaMail sending problem" New topic
Author

JavaMail sending problem

Vassili Vladimir
Ranch Hand

Joined: Mar 08, 2007
Posts: 1585
Hi,

I'm trying to use JavaMail but it's not actually sending.

This is my source code:



Note that mail@domain.com and SERVER_IP are all substituted with values in real code and are not being shown here for security reasons.

When i run the code, the sent ... is being printed, but no mail is being sent or received.

What could be the problem ?

Thanks,

Vassili ...
SCJP 5.0, SCWCD 1.4, SCJA 1.0
Rob Spoor
Sheriff

Joined: Oct 27, 2005
Posts: 20078
    
  30

Change the value of debug to true and post the output then please.


SCJP 1.4 - SCJP 6 - SCWCD 5 - OCEEJBD 6 - OCEJPAD 6
How To Ask Questions How To Answer Questions
 
I’ve looked at a lot of different solutions, and in my humble opinion Aspose is the way to go. Here’s the link: http://aspose.com
 
subject: JavaMail sending problem
 
It's not a secret anymore!