This week's book giveaway is in the OCMJEA forum.
We're giving away four copies of OCM Java EE 6 Enterprise Architect Exam Guide and have Paul Allen & Joseph Bambara on-line!
See this thread for details.
The moose likes Struts and the fly likes <jsp:include TO_ACTION/> do not work on WAS 6.1 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of OCM Java EE 6 Enterprise Architect Exam Guide this week in the OCMJEA forum!
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "<jsp:include TO_ACTION/> do not work on WAS 6.1" Watch "<jsp:include TO_ACTION/> do not work on WAS 6.1" New topic
Author

<jsp:include TO_ACTION/> do not work on WAS 6.1

Sebastiao Santos
Greenhorn

Joined: Jun 12, 2003
Posts: 5
Hi,

I'm having problems to compose pages with <jsp:include .../> on WAS, on JBoss x Tomcat every works fine.

I've tried a lot, but my <jsp:include page="bla.action" /> do not work in Websphere 6.1.

Everytime I get a recursive include to my home page.

If I remove the <jsp:include ...> to action and put data + include to jsp rendering the data, all works fine.

I have JAAS protecting all my actions, but this happens after I've got success login.

As I'm desperated and tried everything, now I'm trying not to use the Struts2 Filters, but one Servlet as dispatcher to prepare and execute the actions like above:


I'm not using sitemesh, but have struts clean up filters up and running:


When I was using FilterDispatcher, I've used FORWARD, REQUEST, INCLUDE, ERROR as dispatching, but, none works.

On my struts.xml I have something like:


Someone knows what is happening with my jsp:include *.action ?

[]'s
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: <jsp:include TO_ACTION/> do not work on WAS 6.1